summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2020-07-30 18:08:59 -0400
committerJune McEnroe <june@causal.agency>2020-08-02 15:42:48 -0400
commite5c08e2f0787eb1a1532ea3c0957892250007b07 (patch)
tree921d6f382ee385d9a640eb5832b6b0830b5b1fc8 /configure.ac
parentbuild: Add ax_check_openssl (diff)
downloadlibretls-e5c08e2f0787eb1a1532ea3c0957892250007b07.tar.gz
libretls-e5c08e2f0787eb1a1532ea3c0957892250007b07.zip
build: Strip down build
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac90
1 files changed, 4 insertions, 86 deletions
diff --git a/configure.ac b/configure.ac
index 888ca19..42c4c9b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,10 +12,8 @@
 # ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
 # OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
 
-AC_INIT([libressl], m4_esyscmd([tr -d '\n' < VERSION]))
-AC_SUBST([LIBCRYPTO_VERSION], m4_esyscmd([tr -d '\n' < crypto/VERSION]))
-AC_SUBST([LIBSSL_VERSION], m4_esyscmd([tr -d '\n' < ssl/VERSION]))
-AC_SUBST([LIBTLS_VERSION], m4_esyscmd([tr -d '\n' < tls/VERSION]))
+AC_INIT([libretls], m4_esyscmd([tr -d '\n' < VERSION]))
+AC_SUBST([LIBTLS_VERSION], m4_esyscmd([tr -d '\n' < LIBTLS_VERSION]))
 
 AC_CANONICAL_HOST
 AM_INIT_AUTOMAKE([subdir-objects foreign])
@@ -41,61 +39,9 @@ AM_PROG_AS
 
 DISABLE_COMPILER_WARNINGS
 
-# Check if the certhash command should be built
-AC_CHECK_FUNCS([symlink])
-AM_CONDITIONAL([BUILD_CERTHASH], [test "x$ac_cv_func_symlink" = xyes])
-
-# Check if funopen exists
-AC_CHECK_FUNC([funopen])
-
 CHECK_LIBC_COMPAT
-CHECK_SYSCALL_COMPAT
 CHECK_CRYPTO_COMPAT
 CHECK_VA_COPY
-CHECK_B64_NTOP
-
-AC_ARG_WITH([openssldir],
-	AS_HELP_STRING([--with-openssldir],
-		       [Set the default openssl directory]),
-	OPENSSLDIR="$withval"
-	AC_SUBST(OPENSSLDIR)
-)
-AM_CONDITIONAL([OPENSSLDIR_DEFINED], [test x$with_openssldir != x])
-
-AC_ARG_ENABLE([extratests],
-	AS_HELP_STRING([--enable-extratests], [Enable extra tests that may be unreliable on some platforms]))
-AM_CONDITIONAL([ENABLE_EXTRATESTS], [test "x$enable_extratests" = xyes])
-
-AC_ARG_ENABLE([tests],
-       [AS_HELP_STRING([--disable-tests], [Disable tests @<:@default=enabled@:>@])],
-       [
-        if ! test "x${enable_tests}" = "xyes"; then
-		enable_tests="no"
-	fi],
-       [enable_tests="yes"])
-AM_CONDITIONAL([ENABLE_TESTS], [test "x$enable_tests" = xyes])
-
-# Add CPU-specific alignment flags
-old_cflags=$CFLAGS
-CFLAGS="$CFLAGS -I$srcdir/include"
-AC_MSG_CHECKING([if BSWAP4 builds without __STRICT_ALIGNMENT])
-AC_TRY_COMPILE([#include "$srcdir/crypto/modes/modes_lcl.h"],
-	       [int a = 0; BSWAP4(a);],
-	       AC_MSG_RESULT([yes])
-	       BSWAP4=yes,
-	       AC_MSG_RESULT([no])
-	       BSWAP4=no)
-CFLAGS="$old_cflags"
-
-AS_CASE([$host_cpu],
-	[*sparc*], [CPPFLAGS="$CPPFLAGS -D__STRICT_ALIGNMENT"],
-	[*arm*], [host_cpu=arm],
-	[*amd64*], [host_cpu=x86_64 HOSTARCH=intel],
-	[i?86], [HOSTARCH=intel],
-	[x86_64], [HOSTARCH=intel]
-)
-AS_IF([test "x$BSWAP4" = "xyes" -a "$host_cpu" = "arm" ],,CPPFLAGS="$CPPFLAGS -D__STRICT_ALIGNMENT")
-AM_CONDITIONAL([HOST_CPU_IS_INTEL], [test "x$HOSTARCH" = "xintel"])
 
 AC_MSG_CHECKING([if .gnu.warning accepts long strings])
 AC_LINK_IFELSE([AC_LANG_SOURCE([[
@@ -109,42 +55,16 @@ int main() {return 0;}
    AC_MSG_RESULT(no)
 ])
 
-AC_ARG_ENABLE([asm],
-	AS_HELP_STRING([--disable-asm], [Disable assembly]))
-AM_CONDITIONAL([OPENSSL_NO_ASM], [test "x$enable_asm" = "xno"])
-
-# Conditionally enable assembly by default
-AM_CONDITIONAL([HOST_ASM_ELF_ARM],
-    [test "x$HOST_ABI" = "xelf" -a "$host_cpu" = "arm" -a "x$enable_asm" != "xno"])
-AM_CONDITIONAL([HOST_ASM_ELF_X86_64],
-    [test "x$HOST_ABI" = "xelf" -a "$host_cpu" = "x86_64" -a "x$enable_asm" != "xno"])
-AM_CONDITIONAL([HOST_ASM_MACOSX_X86_64],
-    [test "x$HOST_ABI" = "xmacosx" -a "$host_cpu" = "x86_64" -a "x$enable_asm" != "xno"])
-AM_CONDITIONAL([HOST_ASM_MASM_X86_64],
-    [test "x$HOST_ABI" = "xmasm" -a "$host_cpu" = "x86_64" -a "x$enable_asm" != "xno"])
-AM_CONDITIONAL([HOST_ASM_MINGW64_X86_64],
-    [test "x$HOST_ABI" = "xmingw64" -a "$host_cpu" = "x86_64" -a "x$enable_asm" != "xno"])
-
 # Check if time_t is sized correctly
 AC_CHECK_SIZEOF([time_t], [time.h])
 
+AX_CHECK_OPENSSL([], [AC_MSG_ERROR([unable to find OpenSSL])])
+
 AC_CONFIG_FILES([
 	Makefile
 	include/Makefile
-	include/openssl/Makefile
-	crypto/Makefile
-	ssl/Makefile
-	tls/Makefile
-	tests/Makefile
-	apps/Makefile
-	apps/ocspcheck/Makefile
-	apps/openssl/Makefile
-	apps/nc/Makefile
 	man/Makefile
-	libcrypto.pc
-	libssl.pc
 	libtls.pc
-	openssl.pc
 ])
 
 AM_CONDITIONAL([SMALL_TIME_T], [test "$ac_cv_sizeof_time_t" = "4"])
@@ -160,6 +80,4 @@ if test "$ac_cv_sizeof_time_t" = "4"; then
     fi
 fi
 
-AC_REQUIRE_AUX_FILE([tap-driver.sh])
-
 AC_OUTPUT