summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorHerbert Xu <herbert@gondor.apana.org.au>2020-07-22 13:58:47 +1000
committerHerbert Xu <herbert@gondor.apana.org.au>2020-08-28 13:06:30 +1000
commit0493bbfcbdff707fad353fc5457ad3a98d835b38 (patch)
tree5226fb04bf65422b152ecde23597e1677cc80df2 /configure.ac
parentRelease 0.5.11.1. (diff)
downloaddash-0493bbfcbdff707fad353fc5457ad3a98d835b38.tar.gz
dash-0493bbfcbdff707fad353fc5457ad3a98d835b38.zip
shell: Group readdir64/dirent64 with open64
The test for open64 is separate from stat64 for macOS.  However,
the newly introduced tests for readdir64/dirent64 should be grouped
with open64 instead of stat64 as otherwise they cause similar build
failures.

Reported-by: Martijn Dekker <martijn@inlv.org>
Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
Diffstat (limited to '')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b8faca9..6041a46 100644
--- a/configure.ac
+++ b/configure.ac
@@ -144,15 +144,15 @@ AC_CHECK_FUNC(stat64,, [
 	AC_DEFINE(fstat64, fstat, [64-bit operations are the same as 32-bit])
 	AC_DEFINE(lstat64, lstat, [64-bit operations are the same as 32-bit])
 	AC_DEFINE(stat64, stat, [64-bit operations are the same as 32-bit])
-	AC_DEFINE(readdir64, readdir,
-		  [64-bit operations are the same as 32-bit])
-	AC_DEFINE(dirent64, dirent,
-		  [64-bit operations are the same as 32-bit])
 ])
 
 dnl OS X apparently has stat64 but not open64.
 AC_CHECK_FUNC(open64,, [
 	AC_DEFINE(open64, open, [64-bit operations are the same as 32-bit])
+	AC_DEFINE(readdir64, readdir,
+		  [64-bit operations are the same as 32-bit])
+	AC_DEFINE(dirent64, dirent,
+		  [64-bit operations are the same as 32-bit])
 ])
 
 dnl Check if struct stat has st_mtim.