summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Bowen <bowen.pi@gmail.com>2018-03-26 13:53:39 -0500
committerHerbert Xu <herbert@gondor.apana.org.au>2018-04-19 18:19:29 +0800
commite695774716a91b07234a3f531bde50f865cb206a (patch)
tree0c86023448d252cb0aaaa30bc53cabd7a2147181 /configure.ac
parenteval: Restore input files in evalcommand (diff)
downloaddash-e695774716a91b07234a3f531bde50f865cb206a.tar.gz
dash-e695774716a91b07234a3f531bde50f865cb206a.zip
shell: Add subdir-objects to AM_INIT_AUTOMAKE
I've attached a patch which adds the subdir-objects option to AM_INIT_AUTOMAKE.

For a while now when I've compiled dash I received a warning from
automake that there are source files in a subdirectory but that the
subdir-objects automake option was not supplied. I've just been adding
it myself, but I finally got around to submitting a patch. The code
still compiles for now (i'm using automake 1.15.1), but warning text
is rarely nice to see and, if the warning text is to be believed, then
the warning will eventually become an error.

Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
Diffstat (limited to '')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0417fa2..5d88894 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
 AC_INIT(dash, 0.5.9.1)
-AM_INIT_AUTOMAKE([foreign])
+AM_INIT_AUTOMAKE([foreign subdir-objects])
 AC_CONFIG_SRCDIR([src/main.c])
 
 AC_CONFIG_HEADERS(config.h)