summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configure.ac21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..f442ebf
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,21 @@
+dnl $Id$
+AC_INIT(dash, 0.5.1)
+AM_INIT_AUTOMAKE
+AC_CONFIG_SRCDIR([src/main.c])
+
+AC_CONFIG_HEADERS(config.h)
+
+dnl Checks for programs.
+AC_PROG_CC
+AC_GNU_SOURCE
+AC_PROG_YACC
+
+dnl Checks for libraries.
+
+dnl Checks for header files.
+
+dnl Checks for library functions.
+AC_CHECK_FUNCS(mempcpy sigsetmask stpcpy strchrnul strtoimax strtoumax)
+
+AC_CONFIG_FILES([Makefile src/Makefile])
+AC_OUTPUT