summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2021-04-18 17:54:23 -0400
committerJune McEnroe <june@causal.agency>2021-04-18 17:54:23 -0400
commit3bb2203d08dbddd9356334d350275be577e9fa84 (patch)
treedfc4bf1648d4e0e4d3161267235b1b392e832228 /configure.ac
parentBump version to 3.3.1p1 (diff)
parentImport LibreSSL 3.3.2 (diff)
downloadlibretls-3bb2203d08dbddd9356334d350275be577e9fa84.tar.gz
libretls-3bb2203d08dbddd9356334d350275be577e9fa84.zip
Merge LibreSSL 3.3.2 into master
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 0 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index f2a27a9..150a6d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,9 +54,6 @@ int main() {return 0;}
    AC_MSG_RESULT(no)
 ])
 
-# Check if time_t is sized correctly
-AC_CHECK_SIZEOF([time_t], [time.h])
-
 AX_CHECK_OPENSSL([], [AC_MSG_ERROR([unable to find OpenSSL])])
 
 AC_CONFIG_FILES([
@@ -66,17 +63,4 @@ AC_CONFIG_FILES([
 	libtls.pc
 ])
 
-AM_CONDITIONAL([SMALL_TIME_T], [test "$ac_cv_sizeof_time_t" = "4"])
-if test "$ac_cv_sizeof_time_t" = "4"; then
-    AC_DEFINE([SMALL_TIME_T])
-    echo " ** Warning, this system is unable to represent times past 2038"
-    echo " ** It will behave incorrectly when handling valid RFC5280 dates"
-
-    if test "$host_os" = "mingw32" ; then
-        echo " **"
-        echo " ** You can solve this by adjusting the build flags in your"
-        echo " ** mingw-w64 toolchain. Refer to README.windows for details."
-    fi
-fi
-
 AC_OUTPUT