summary refs log tree commit diff
path: root/include/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--include/Makefile.am36
1 files changed, 1 insertions, 35 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 077637d..d76e32e 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -1,62 +1,28 @@
 include $(top_srcdir)/Makefile.am.common
 
-EXTRA_DIST = CMakeLists.txt
-
-SUBDIRS = openssl
-
-noinst_HEADERS = pqueue.h
-noinst_HEADERS += compat/dirent.h
-noinst_HEADERS += compat/dirent_msvc.h
-noinst_HEADERS += compat/endian.h
-noinst_HEADERS += compat/err.h
-noinst_HEADERS += compat/fcntl.h
+noinst_HEADERS = compat/fcntl.h
 noinst_HEADERS += compat/limits.h
 noinst_HEADERS += compat/netdb.h
-noinst_HEADERS += compat/poll.h
 noinst_HEADERS += compat/pthread.h
-noinst_HEADERS += compat/readpassphrase.h
-noinst_HEADERS += compat/resolv.h
 noinst_HEADERS += compat/stdio.h
 noinst_HEADERS += compat/stdlib.h
 noinst_HEADERS += compat/string.h
-noinst_HEADERS += compat/syslog.h
 noinst_HEADERS += compat/time.h
 noinst_HEADERS += compat/unistd.h
 noinst_HEADERS += compat/win32netcompat.h
 
 noinst_HEADERS += compat/arpa/inet.h
-noinst_HEADERS += compat/arpa/nameser.h
 
 noinst_HEADERS += compat/netinet/in.h
 noinst_HEADERS += compat/netinet/ip.h
 noinst_HEADERS += compat/netinet/tcp.h
 
-noinst_HEADERS += compat/sys/_null.h
 noinst_HEADERS += compat/sys/ioctl.h
 noinst_HEADERS += compat/sys/mman.h
 noinst_HEADERS += compat/sys/param.h
-noinst_HEADERS += compat/sys/queue.h
-noinst_HEADERS += compat/sys/select.h
 noinst_HEADERS += compat/sys/socket.h
 noinst_HEADERS += compat/sys/stat.h
-noinst_HEADERS += compat/sys/tree.h
 noinst_HEADERS += compat/sys/time.h
 noinst_HEADERS += compat/sys/types.h
-noinst_HEADERS += compat/sys/uio.h
-
-noinst_HEADERS += arch/aarch64/opensslconf.h
-noinst_HEADERS += arch/alpha/opensslconf.h
-noinst_HEADERS += arch/amd64/opensslconf.h
-noinst_HEADERS += arch/arm/opensslconf.h
-noinst_HEADERS += arch/hppa/opensslconf.h
-noinst_HEADERS += arch/i386/opensslconf.h
-noinst_HEADERS += arch/m88k/opensslconf.h
-noinst_HEADERS += arch/mips/opensslconf.h
-noinst_HEADERS += arch/mips64/opensslconf.h
-noinst_HEADERS += arch/powerpc/opensslconf.h
-noinst_HEADERS += arch/powerpc64/opensslconf.h
-noinst_HEADERS += arch/riscv64/opensslconf.h
-noinst_HEADERS += arch/sh/opensslconf.h
-noinst_HEADERS += arch/sparc64/opensslconf.h
 
 include_HEADERS = tls.h
usal.agency like bin HTMLJune McEnroe 2021-01-12Avoid matching tag text inside HTML elementsJune McEnroe 2021-01-12Use hilex for up -hJune McEnroe 2021-01-12Use hilex for bin HTMLJune McEnroe 2021-01-12Don't output a pre in hilex by defaultJune McEnroe 2021-01-12Move hilex out of hilex directoryJune McEnroe 2021-01-12Consolidate hilex formatters into hilex.cJune McEnroe 2021-01-12Remove hacky tagging from hilexJune McEnroe God that makes the lexers so much simpler. 2021-01-12Add htagml -iJune McEnroe 2021-01-12Render tag index in HTMLJune McEnroe 2021-01-12Add htagml -xJune McEnroe 2021-01-12Prevent matching the same tag twiceJune McEnroe 2021-01-12Process htagml file line by lineJune McEnroe This simplifies some things, adds support for line number tag definitions, and should enable combining htagml with other preprocessors in the future. 2021-01-12Split fields by tab onlyJune McEnroe Also don't fail hard on non-forward-search definitions. 2021-01-12List both Makefile and html.sh under README.7June McEnroe 2021-01-12Add htagml exampleJune McEnroe 2021-01-12Use mandoc and htagml for bin htmlJune McEnroe 2021-01-12Add htagmlJune McEnroe 2021-01-12Replace causal.agency with a simple mdoc pageJune McEnroe 2021-01-11Publish "Using vi"June McEnroe 2021-01-11Enable diff.colorMovedJune McEnroe 2021-01-10Set less search case-insensitiveJune McEnroe 2021-01-10Set EXINITJune McEnroe neovim is laggy as hell in my OpenBSD VM, so I switched to vi so I could type without getting frustrated. 2021-01-09Add c -t flag to print expression typeJune McEnroe Also add missing float case. 2021-01-05Update taglineJune McEnroe