summary refs log tree commit diff
path: root/bin/dash/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--bin/dash/configure.ac (renamed from configure.ac)9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/bin/dash/configure.ac
index d06b9044..dc96b748 100644
--- a/configure.ac
+++ b/bin/dash/configure.ac
@@ -169,18 +169,21 @@ if test "$have_st_mtim" = "yes"; then
 		[Define if your `struct stat' has `st_mtim'])
 fi
 
-AC_ARG_WITH(libedit, AS_HELP_STRING(--with-libedit, [Compile with libedit support]))
+AC_ARG_WITH(libedit,
+	AS_HELP_STRING(--without-libedit, [Compile without libedit support]))
 use_libedit=
-if test "$with_libedit" = "yes"; then
+if test "$with_libedit" != "no"; then
 	AC_CHECK_LIB(edit, history_init, [
 		AC_CHECK_HEADER([histedit.h], [use_libedit="yes"],
 				AC_MSG_ERROR(
-					[Can't find required header files.]))])
+					[Can't find required header files.]))], [
+		AC_MSG_ERROR([Can't find libedit.])])
 fi
 if test "$use_libedit" != "yes"; then
 	AC_DEFINE([SMALL], 1, [Define if you build with -DSMALL])
 else
 	export LIBS="$LIBS -ledit"
+	AC_CHECK_FUNCS(_el_fn_sh_complete)
 fi
 AC_ARG_ENABLE(lineno, AS_HELP_STRING(--disable-lineno, \
 				     [Disable LINENO support]))