about summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..9a40c37
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,18 @@
+cmake_minimum_required(VERSION 3.10)
+
+project(cards C)
+
+find_package(SDL2 REQUIRED)
+
+if(NOT MSVC)
+	add_compile_options(-Wall -Wextra -pedantic)
+endif()
+
+add_library(cards STATIC cards.c)
+target_link_libraries(cards SDL2::SDL2)
+
+add_executable(example EXCLUDE_FROM_ALL example.c)
+target_link_libraries(example cards SDL2::SDL2main)
+
+add_executable(dump EXCLUDE_FROM_ALL dump.c)
+target_link_libraries(dump cards)