summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2022-01-21 22:26:28 -0500
committerJune McEnroe <june@causal.agency>2022-01-21 22:26:28 -0500
commit22fb2a07db173532462d90ad875a06254e932773 (patch)
treef1452b68dad10fa2a6d43223a992eefa93cedf75 /CMakeLists.txt
parentdash: Just zero mailsize on changemail (diff)
downloaddash-22fb2a07db173532462d90ad875a06254e932773.tar.gz
dash-22fb2a07db173532462d90ad875a06254e932773.zip
dash: Stop this stat64 nonsense
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 0 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9fc4bc8..4871b35 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -114,18 +114,6 @@ if(HAVE_BSD_SIGNAL)
 	add_compile_definitions(signal=bsd_signal)
 endif()
 
-# Check for stat64 (dietlibc/klibc).
-check_symbol_exists(stat64 "sys/stat.h" HAVE_STAT64)
-if(NOT HAVE_STAT64)
-	add_compile_definitions(fstat64=fstat lstat64=lstat stat64=stat)
-endif()
-
-# OS X apparently has stat64 but not open64.
-check_symbol_exists(open64 "fcntl.h" HAVE_OPEN64)
-if(NOT HAVE_OPEN64)
-	add_compile_definitions(open64=open readdir64=readdir dirent64=dirent)
-endif()
-
 # Check if struct stat has st_mtim.
 check_struct_has_member(
 	"struct stat" "st_mtim.tv_sec" "sys/stat.h" HAVE_ST_MTIM