summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorAntonio Ospite <ao2@ao2.it>2018-10-16 18:42:16 +0200
committerHerbert Xu <herbert@gondor.apana.org.au>2018-12-14 13:48:02 +0800
commit49cd00921746c634a03e141287cd507f7309dc81 (patch)
tree279e3bc90f9422fc25623ad8934dc7237fa5f1c1 /configure.ac
parenteval: make traps work when "set -e" is enabled (diff)
downloaddash-49cd00921746c634a03e141287cd507f7309dc81.tar.gz
dash-49cd00921746c634a03e141287cd507f7309dc81.zip
shell: Update configure.ac with suggestions from autoupdate
Apply the changes suggested by running autoupdate on the source
repository:

1. Properly quote AC_INIT arguments.

2. Use AC_USE_SYSTEM_EXTENSIONS instead of AC_GNU_SOURCE. The former is
   a superset of the latter, and enables more options, see
   https://www.gnu.org/software/autoconf/manual/autoconf-2.60/html_node/Posix-Variants.html

Signed-off-by: Antonio Ospite <ao2@ao2.it>
Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4829288..594fb42 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT(dash, 0.5.10.2)
+AC_INIT([dash],[0.5.10.2])
 AM_INIT_AUTOMAKE([foreign subdir-objects])
 AC_CONFIG_SRCDIR([src/main.c])
 
@@ -6,7 +6,7 @@ AC_CONFIG_HEADERS(config.h)
 
 dnl Checks for programs.
 AC_PROG_CC
-AC_GNU_SOURCE
+AC_USE_SYSTEM_EXTENSIONS
 AC_PROG_YACC
 
 AC_MSG_CHECKING([for build system compiler])