summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorHerbert Xu <herbert@gondor.apana.org.au>2005-10-29 14:15:26 +1000
committerHerbert Xu <herbert@gondor.apana.org.au>2005-10-29 14:15:26 +1000
commit90829c10d5712f24b4bd6cfcee5406cf26edb955 (patch)
tree4a593f0b20536472bba65a59547e27c3a7e61856 /configure.ac
parent[SIGNAL] Removed use of __P from error.h (diff)
downloaddash-90829c10d5712f24b4bd6cfcee5406cf26edb955.tar.gz
dash-90829c10d5712f24b4bd6cfcee5406cf26edb955.zip
[SIGNAL] Use bsd_signal if it exists and signal does not
klibc has bsd_signal instead of signal.  So we will define signal as
bsd_signal if

1) signal does not exist.
2) bsd_signal exists.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1d27654..a64e666 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,5 +25,13 @@ dnl Checks for header files.
 dnl Checks for library functions.
 AC_CHECK_FUNCS(mempcpy sigsetmask stpcpy strchrnul strtoimax strtoumax)
 
+dnl Check for klibc signal.
+AC_CHECK_FUNC(signal)
+if test "$ac_cv_func_signal" != yes; then
+	AC_CHECK_FUNC(bsd_signal,
+		      [AC_DEFINE(signal, bsd_signal,
+				 [klibc has bsd_signal instead of signal])])
+fi
+
 AC_CONFIG_FILES([Makefile src/Makefile])
 AC_OUTPUT