summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald van Dijk <harald@gigawatt.nl>2011-08-17 09:28:24 +0800
committerHerbert Xu <herbert@gondor.apana.org.au>2011-08-17 09:28:24 +0800
commitb5bda1d94f7a62d88c6a257a283426c16906c8cb (patch)
tree06613b5c3f6061702960e49dada94be9436241fc /configure.ac
parent[SHELL] Fix klibc DEBUG compilation (diff)
downloaddash-b5bda1d94f7a62d88c6a257a283426c16906c8cb.tar.gz
dash-b5bda1d94f7a62d88c6a257a283426c16906c8cb.zip
[ARITH] Avoid imaxdiv when only one of the results is wanted
dash rather pointlessly calls imaxdiv, only to discard one of its
results. The call was already made conditional a while back because some
systems don't have imaxdiv, but the generated code for the version with
imaxdiv and the one with / and % is identical (with GCC 4.6.1 or ICC
12.0.2, with -O0, -O2 or -Os), so it could just as well go entirely to
clean up the code a little bit.

Signed-off-by: Harald van Dijk <harald@gigawatt.nl>
Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7eae954..5cd6e95 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,7 +85,7 @@ AC_CHECK_DECL([PRIdMAX],,
 ])
 
 dnl Checks for library functions.
-AC_CHECK_FUNCS(bsearch faccessat getpwnam getrlimit imaxdiv isalpha killpg \
+AC_CHECK_FUNCS(bsearch faccessat getpwnam getrlimit isalpha killpg \
 	       mempcpy \
 	       sigsetmask stpcpy strchrnul strsignal strtod strtoimax \
 	       strtoumax sysconf)