summary refs log tree commit diff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHerbert Xu <herbert@gondor.apana.org.au>2005-10-29 11:26:30 +1000
committerHerbert Xu <herbert@gondor.apana.org.au>2005-10-29 11:26:30 +1000
commit16399b907190e556d56e54eecd1121d13d124811 (patch)
tree6015d732531031ae15ac185d561bb6d4d82aac39 /src/Makefile.am
parent[INPUT] Size optimisations in preadbuffer() (diff)
downloaddash-16399b907190e556d56e54eecd1121d13d124811.tar.gz
dash-16399b907190e556d56e54eecd1121d13d124811.zip
Copyright/licence updates and remove all traces of sys/cdefs.h
This change updates the BSD licence to the three-clause version since
NetBSD has already done so.  This makes dash GPL-compatible.

It also adds Christos Zoulas (NetBSD ash maintainer) to the COPYING file.
I've added "copyright by Herbert Xu" to most files.

Finally all CVS IDs and inclusion of sys/cdefs.h have been removed.
The latter is needed for support of klibc.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 4e05be8..d8acd39 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,13 +1,10 @@
-# $Id$
-
 AM_YFLAGS = -d
 
 COMMON_CFLAGS = -Wall
 COMMON_CPPFLAGS = \
 	-include $(top_builddir)/config.h \
 	-DBSD=1 -DSMALL -DSHELL \
-	-DGLOB_BROKEN -DFNMATCH_BROKEN -DIFS_BROKEN \
-	-D__COPYRIGHT\(x\)= -D__RCSID\(x\)= -D_DIAGASSERT\(x\)=
+	-DGLOB_BROKEN -DFNMATCH_BROKEN -DIFS_BROKEN
 
 AM_CFLAGS = $(COMMON_CFLAGS)
 AM_CPPFLAGS = $(COMMON_CPPFLAGS)