summary refs log tree commit diff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJonathan Perkin <jperkin@joyent.com>2015-12-11 11:56:43 +0000
committerHerbert Xu <herbert@gondor.apana.org.au>2016-06-06 22:25:00 +0800
commitcb924afe2e3465ec2f91fab55d31f7e3c26d03f4 (patch)
tree455df31bbf9b1d1d1f1673dbc661cc355245a75c /src/Makefile.am
parentjobs: Don't attempt to access job table for job %0 (diff)
downloaddash-cb924afe2e3465ec2f91fab55d31f7e3c26d03f4.tar.gz
dash-cb924afe2e3465ec2f91fab55d31f7e3c26d03f4.zip
shell: Fix build on Solaris 9
Ensure dash can build in a default Solaris 9 or older environment:

 - Execute scripts with $SHELL rather than /bin/sh, the latter does not
   support e.g. "if ! .." used by mkbuiltins.

 - /bin/awk does not support ?: syntax, use explicit statements instead.

 - /bin/nl requires no spaces between options and arguments.

Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 120ffa2..139355e 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -46,13 +46,13 @@ EXTRA_DIST = \
 	mknodes.c nodetypes nodes.c.pat mksyntax.c mksignames.c
 
 token.h token_vars.h: mktokens
-	sh $^
+	$(SHELL) $^
 
 builtins.def: builtins.def.in $(top_builddir)/config.h
 	$(COMPILE) -E -x c -o $@ $<
 
 builtins.c builtins.h: mkbuiltins builtins.def
-	sh $^
+	$(SHELL) $^
 
 init.c: mkinit $(dash_CFILES)
 	./$^