summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 0 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9fc4bc8..4871b35 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -114,18 +114,6 @@ if(HAVE_BSD_SIGNAL)
 	add_compile_definitions(signal=bsd_signal)
 endif()
 
-# Check for stat64 (dietlibc/klibc).
-check_symbol_exists(stat64 "sys/stat.h" HAVE_STAT64)
-if(NOT HAVE_STAT64)
-	add_compile_definitions(fstat64=fstat lstat64=lstat stat64=stat)
-endif()
-
-# OS X apparently has stat64 but not open64.
-check_symbol_exists(open64 "fcntl.h" HAVE_OPEN64)
-if(NOT HAVE_OPEN64)
-	add_compile_definitions(open64=open readdir64=readdir dirent64=dirent)
-endif()
-
 # Check if struct stat has st_mtim.
 check_struct_has_member(
 	"struct stat" "st_mtim.tv_sec" "sys/stat.h" HAVE_ST_MTIM
an>Use scrot for up -s if no screencaptureJune McEnroe 2021-02-07Enable mouse acceleration in XJune McEnroe 2021-02-07Set colours for Xt and cwmJune McEnroe 2021-02-07Set urgency on bell in xtermJune McEnroe 2021-02-07Add bindings for brightness controlJune McEnroe 2021-02-07Set X key repeat rateJune McEnroe 2021-02-07Bump font size to 12June McEnroe 2021-02-07Fully configure and rebind cwmJune McEnroe 2021-02-07Add BintiJune McEnroe 2021-02-07Finish configuring xtermJune McEnroe 2021-02-06Enable tapping, reverse scroll, set scaling in wsconsctlJune McEnroe 2021-02-06Set root window to black on purple snowJune McEnroe 2021-02-06Add xmodmap configurationJune McEnroe 2021-02-06Add initial OpenBSD X configurationJune McEnroe 2021-02-06Add xterm output to schemeJune McEnroe