summary refs log tree commit diff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5385049..9fc4bc8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -140,6 +140,10 @@ if(WITH_LIBEDIT)
 	else()
 		message(SEND_ERROR "Can't find libedit.")
 	endif()
+	set(CMAKE_REQUIRED_LIBRARIES edit)
+	check_symbol_exists(
+		_el_fn_sh_complete "histedit.h" HAVE__EL_FN_SH_COMPLETE
+	)
 else()
 	add_compile_definitions(SMALL)
 endif()