summary refs log tree commit diff
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2020-08-06 18:46:51 +0000
committerJune McEnroe <june@causal.agency>2020-08-06 18:48:00 +0000
commit53301b81f62359dc647e8f1fe22f0e1b456e818f (patch)
tree101bf07033c4aad06305a52a691b7a36c3ce143c
parentIgnore work directories (diff)
downloadports-53301b81f62359dc647e8f1fe22f0e1b456e818f.tar.gz
ports-53301b81f62359dc647e8f1fe22f0e1b456e818f.zip
Add pounce port
Diffstat (limited to '')
-rw-r--r--irc/pounce/Makefile25
-rw-r--r--irc/pounce/distinfo3
-rw-r--r--irc/pounce/pkg-descr5
-rw-r--r--irc/pounce/pkg-plist8
4 files changed, 41 insertions, 0 deletions
diff --git a/irc/pounce/Makefile b/irc/pounce/Makefile
new file mode 100644
index 0000000..6a5c656
--- /dev/null
+++ b/irc/pounce/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME=	pounce
+DISTVERSION=	1.3p1
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/pounce/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Multi-client IRC bouncer
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libressl
+RUN_DEPENDS=	${LOCALBASE}/bin/openssl:security/libressl
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+post-install:
+.for b in calico pounce
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${b}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/irc/pounce/distinfo b/irc/pounce/distinfo
new file mode 100644
index 0000000..5c271d9
--- /dev/null
+++ b/irc/pounce/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1596739669
+SHA256 (pounce-1.3p1.tar.gz) = 6093c25233315d3d926db131219d1bb93d3714746c9eb8437e45e28a703d4873
+SIZE (pounce-1.3p1.tar.gz) = 40679
diff --git a/irc/pounce/pkg-descr b/irc/pounce/pkg-descr
new file mode 100644
index 0000000..68679a2
--- /dev/null
+++ b/irc/pounce/pkg-descr
@@ -0,0 +1,5 @@
+pounce is a multi-client, TLS-only IRC bouncer. It takes a simple
+approach, using a multiple-consumer ring buffer and the IRCv3.2
+server-time extension to communicate with clients.
+
+WWW: https://git.causal.agency/pounce/
diff --git a/irc/pounce/pkg-plist b/irc/pounce/pkg-plist
new file mode 100644
index 0000000..a0de441
--- /dev/null
+++ b/irc/pounce/pkg-plist
@@ -0,0 +1,8 @@
+@dir /var/run/calico
+@dir etc/pounce
+bin/calico
+bin/pounce
+etc/rc.d/calico
+etc/rc.d/pounce
+man/man1/calico.1.gz
+man/man1/pounce.1.gz
-0500'>2018-03-05Generate tagsJune McEnroe 2017-10-03Simplify Makefile with pattern ruleJune McEnroe Insert rant about how GNU make handles the .c rule with extra dependencies. Also I don't care that everything links curses now. 2017-09-27Remove leading blank linesJune McEnroe 2017-09-27Add merge.c to READMEJune McEnroe 2017-09-03Assert client coords are valid after movementJune McEnroe 2017-09-03Relicense AGPLJune McEnroe I know it's already published under a permissive license in what is probably its final form, but I want to license it AGPL anyway on principle following some conversations I had about open source, corporations and copyleft. 2017-09-01Revert "Add client readOnly mode"June McEnroe This reverts commit 34f25ae40a3db9369e9d98b3814f2b93bbc21451. 2017-09-01Remove clientRemove call from clientCastJune McEnroe If an error occurs on a client socket during a broadcast, that client will show up in the kqueue loop with EV_EOF and get removed that way. Tested by sending SIGKILL to a client and watching its cursor disappear. 2017-09-01Add client readOnly modeJune McEnroe 2017-08-31Clean up merge toolJune McEnroe Choose the version with the most recent access if the modify times are the same. 2017-08-31Choose B for tiles with equal modify timesJune McEnroe This way newer access counts and times will be preserved. 2017-08-31Add quick data file merge toolJune McEnroe Hopefully I won't have to use it ever again. 2017-08-30Use only foreground color for selecting spawnJune McEnroe 2017-08-29Add four additional spawnsJune McEnroe 2017-08-28Add respawningJune McEnroe 2017-08-26Move license above includesJune McEnroe Why was it down there? 2017-08-26Snapshot metadataJune McEnroe 2017-08-26Add meta.c to READMEJune McEnroe 2017-08-26Use MakefileJune McEnroe