summary refs log tree commit diff
path: root/devel/cgit-causal-agency/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--devel/cgit-causal-agency/Makefile (renamed from devel/cgit-patched/Makefile)16
1 files changed, 9 insertions, 7 deletions
diff --git a/devel/cgit-patched/Makefile b/devel/cgit-causal-agency/Makefile
index 670897e..bc112ea 100644
--- a/devel/cgit-patched/Makefile
+++ b/devel/cgit-causal-agency/Makefile
@@ -1,14 +1,14 @@
 # $FreeBSD: head/devel/cgit/Makefile 523699 2020-01-21 01:37:59Z meta $
 
-PORTNAME=	cgit-patched
-PORTVERSION=	1.2.3p3
+PORTNAME=	cgit-causal-agency
+PORTVERSION=	1.2.3
 CONFLICTS_INSTALL=	cgit
 CATEGORIES=	devel www
-MASTER_SITES=	https://git.causal.agency/cgit/snapshot/:cgit \
+MASTER_SITES=	https://git.causal.agency/src/snapshot/:src \
 		KERNEL_ORG/software/scm/git:git
-DISTFILES=	cgit-${PORTVERSION}${EXTRACT_SUFX}:cgit \
+DISTFILES=	src-${SRC_VERSION}${EXTRACT_SUFX}:src \
 		git-${GIT_VERSION}${EXTRACT_SUFX}:git
-DISTNAME=	cgit-${DISTVERSION}
+DISTNAME=	src-${SRC_VERSION}
 
 MAINTAINER=	june@causal.agency
 COMMENT=	Fast, lightweight web frontend for Git repositories
@@ -18,7 +18,10 @@ LICENSE_FILE=	${WRKSRC}/COPYING
 
 TEST_DEPENDS=	msgfmt:devel/gettext-tools
 
-GIT_VERSION=	2.25.0
+SRC_VERSION=	db652695744cc54584296b54289166b4b21ac407
+GIT_VERSION=	2.25.1
+WRKSRC_SUBDIR=	www/git.causal.agency/cgit
+
 USES=		cpe gmake iconv perl5 python:3.2+,env shebangfix ssl
 CPE_VENDOR=	lars_hjemli
 USE_PERL5=	test
@@ -45,7 +48,6 @@ ASCIIDOC_DESC=	Use asciidoc to preprocess man page
 ASCIIDOC_BUILD_DEPENDS=	a2x:textproc/asciidoc
 
 post-extract:
-	@${RMDIR} ${WRKSRC}/git
 	@${MV} ${WRKDIR}/git-${GIT_VERSION} ${WRKSRC}/git
 
 post-patch: