summary refs log tree commit diff
path: root/irc/catgirl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--irc/catgirl/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/irc/catgirl/Makefile b/irc/catgirl/Makefile
new file mode 100644
index 0000000..cf5d9f9
--- /dev/null
+++ b/irc/catgirl/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME=	catgirl
+DISTVERSION=	1.1
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/catgirl/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	TLS-only terminal IRC client
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libressl
+RUN_DEPENDS=	${LOCALBASE}/bin/openssl:security/libressl
+
+USES=	ncurses \
+	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/catgirl \
+		man/man1/catgirl.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/catgirl
+
+.include <bsd.port.mk>
pan title='2017-08-02 00:55:52 -0400'>2017-08-02Split tile access and modifyJune McEnroe 2017-08-01Madvise RANDOM and NOSYNCJune McEnroe 2017-07-31Fix removing clients from clientCastJune McEnroe 2017-07-31Build with debug infoJune McEnroe 2017-07-31Don't dump tiles in coreJune McEnroe 2017-07-31Use designated initializers for messagesJune McEnroe I did not realize this syntax was so powerful. 2017-07-31Show other clients' cursorsJune McEnroe Also unfuck removing on send failure. 2017-07-31Perform enter as two moves rather than a loopJune McEnroe 2017-07-31Track tile access countsJune McEnroe 2017-07-31Adjust move speed in clientJune McEnroe 2017-07-31Handle large movesJune McEnroe 2017-07-30Optimize builds for chrootJune McEnroe 2017-07-30Persist bright across color changesJune McEnroe 2017-07-30Add index.htmlJune McEnroe 2017-07-30Add snapshot.shJune McEnroe 2017-07-30Fix termcap patch for background colorsJune McEnroe 2017-07-30Update helpJune McEnroe 2017-07-30Fix help to track colorJune McEnroe 2017-07-30Support background colorsJune McEnroe 2017-07-30Track color only client-sideJune McEnroe 2017-07-30Add ostensible support for background colorsJune McEnroe 2017-07-30Add tile create and access timestampsJune McEnroe 2017-07-30Assert stable struct Tile field offsetsJune McEnroe 2017-07-30Add chroot.shJune McEnroe 2017-07-30Add ` commandJune McEnroe 2017-07-30Add sshd_configJune McEnroe 2017-07-30Add termcap patchJune McEnroe