summary refs log tree commit diff
path: root/mail/notemap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/notemap/Makefile')
-rw-r--r--mail/notemap/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/mail/notemap/Makefile b/mail/notemap/Makefile
new file mode 100644
index 0000000..d5d9dd0
--- /dev/null
+++ b/mail/notemap/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME=	notemap
+DISTVERSION=	1.3
+CATEGORIES=	mail
+MASTER_SITES=	https://git.causal.agency/notemap/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	mirror notes to IMAP
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/git-notemap \
+		bin/notemap \
+		man/man1/git-notemap.1.gz \
+		man/man1/notemap.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/notemap
+
+.include <bsd.port.mk>
une McEnroe 2018-03-05Use stdio in merge and metaJune McEnroe 2018-03-05Clean up spawn constantsJune McEnroe 2018-03-05Rename Tile timestamps {create,modify,access}TimeJune McEnroe 2018-03-05Pack message type enumsJune McEnroe 2018-03-05Undef COLOR_ constants in torus.hJune McEnroe 2018-03-05Generate tagsJune McEnroe 2017-10-03Simplify Makefile with pattern ruleJune McEnroe 2017-09-27Remove leading blank linesJune McEnroe 2017-09-27Add merge.c to READMEJune McEnroe 2017-09-03Assert client coords are valid after movementJune McEnroe 2017-09-03Relicense AGPLJune McEnroe 2017-09-01Revert "Add client readOnly mode"June McEnroe 2017-09-01Remove clientRemove call from clientCastJune McEnroe 2017-09-01Add client readOnly modeJune McEnroe 2017-08-31Clean up merge toolJune McEnroe 2017-08-31Choose B for tiles with equal modify timesJune McEnroe 2017-08-31Add quick data file merge toolJune McEnroe 2017-08-30Use only foreground color for selecting spawnJune McEnroe 2017-08-29Add four additional spawnsJune McEnroe 2017-08-28Add respawningJune McEnroe 2017-08-26Move license above includesJune McEnroe 2017-08-26Snapshot metadataJune McEnroe 2017-08-26Add meta.c to READMEJune McEnroe 2017-08-26Use MakefileJune McEnroe