summary refs log tree commit diff
path: root/security/libretls/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--security/libretls/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/security/libretls/Makefile b/security/libretls/Makefile
new file mode 100644
index 0000000..4d4a83a
--- /dev/null
+++ b/security/libretls/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME=	libretls
+PORTVERSION=	3.2.0
+CATEGORIES=	security devel
+MASTER_SITES=	https://causal.agency/libretls/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Port of libtls for OpenSSL
+
+LICENSE=	ISCL
+
+BROKEN_SSL=			libressl
+BROKEN_SSL_REASON_libressl=	libtls is provided by LibreSSL
+
+USES=		libtool pathfix pkgconfig ssl
+USE_LDCONFIG=	yes
+GNU_CONFIGURE=	yes
+CONFIGURE_ARGS+=	--with-openssl=${OPENSSLBASE}
+CFLAGS+=	-fpic -DPIC -Wl,-rpath,${PREFIX}/lib -Wl,--as-needed
+LDFLAGS+=	-pthread
+
+CONFLICTS_INSTALL=	libressl-[0-9]* \
+			libressl-devel-[0-9]*
+
+INSTALL_TARGET=		install-strip
+
+.include <bsd.port.mk>