summary refs log tree commit diff
path: root/sysutils/catsit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--sysutils/catsit/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/sysutils/catsit/Makefile b/sysutils/catsit/Makefile
new file mode 100644
index 0000000..6eae43f
--- /dev/null
+++ b/sysutils/catsit/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME=	catsit
+DISTVERSION=	1.0
+CATEGORIES=	sysutils
+MASTER_SITES=	https://git.causal.agency/catsit/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Process supervisor
+
+LICENSE=	AGPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+PLIST_FILES=	etc/rc.d/catsitd \
+		man/man5/catsit.conf.5.gz \
+		man/man8/catsit.8.gz \
+		man/man8/catsitd.8.gz \
+		sbin/catsit \
+		sbin/catsitd
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/catsitd
+
+.include <bsd.port.mk>
ise keywords at the beginnings of lines with preceeding whitespace are not matched. 2021-01-25Install vi on Linux and nvi on macOSJune McEnroe 2021-01-25Use vi and lessJune McEnroe I haven't used neovim in a couple weeks by now, so I may as well commit this. 2021-01-20Use mtags for sh in source-filterJune McEnroe 2021-01-20Generate tags for sh files in mtagsJune McEnroe Only matches functions declared at the beginnings of lines, but I'm fine with that. 2021-01-20Add messy sh lexerJune McEnroe Surprisingly seems to work for everything I looked at in my repos. 2021-01-20Add all target to git.causal.agency MakefileJune McEnroe 2021-01-20Remove Lua supportJune McEnroe Lua support is unused and the dlsym fwrite/write hacks horrify me. Clean it up. 2021-01-20Fix tests for diff spansJune McEnroe 2021-01-20Avoid matching ':' in make tagsJune McEnroe Otherwise a :: rule includes one of the ':'s in the tag name. 2021-01-19Prefer tag matches not preceded by [[:alnum:]]June McEnroe Otherwise the "id" in "void" matches for "void id". 2021-01-19Escape \ and / in mtags search patternsJune McEnroe 2021-01-20Use mtags in source-filterJune McEnroe 2021-01-19Add mtags to generate tags for make and mdocJune McEnroe 2021-01-19Map tags to IDs using only [[:alnum:]-._]June McEnroe 2021-01-19Don't use a pager if reading standard inputJune McEnroe 2021-01-19Support BSD make syntax and match *.amJune McEnroe These don't really go together, but... 2021-01-19Match tab following escaped newline in make assignmentsJune McEnroe Otherwise it ends up going into Shell state. 2021-01-18Allow matching lexers using first input lineJune McEnroe