summary refs log tree commit diff
path: root/bin/dash/configure.ac
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2020-12-22 18:45:30 -0500
committerJune McEnroe <june@causal.agency>2020-12-22 19:28:22 -0500
commitf5914bfec1ae91dbd0c8f8882bf5483496e91e7d (patch)
tree429d853bed90fb633d97777be295dce890bd02ec /bin/dash/configure.ac
parentBuild with libedit by default (diff)
downloadsrc-f5914bfec1ae91dbd0c8f8882bf5483496e91e7d.tar.gz
src-f5914bfec1ae91dbd0c8f8882bf5483496e91e7d.zip
Bind libedit's secret filename completion function
Check if the FreeBSD (and by extension macOS) _el_fn_sh_complete version
of the function exists, which does shell escaping of completed filenames
before _el_fn_complete learned to.

Tab is bound after calling el_set() and el_source() since the default
bindings set tab to something else, and it should always be filename
completion in the shell.
Diffstat (limited to 'bin/dash/configure.ac')
-rw-r--r--bin/dash/configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/bin/dash/configure.ac b/bin/dash/configure.ac
index 43e71efd..1edc45b8 100644
--- a/bin/dash/configure.ac
+++ b/bin/dash/configure.ac
@@ -183,6 +183,7 @@ if test "$use_libedit" != "yes"; then
 	AC_DEFINE([SMALL], 1, [Define if you build with -DSMALL])
 else
 	export LIBS="$LIBS -ledit"
+	AC_CHECK_FUNCS(_el_fn_sh_complete)
 fi
 AC_ARG_ENABLE(lineno, AS_HELP_STRING(--disable-lineno, \
 				     [Disable LINENO support]))