summary refs log tree commit diff
path: root/cards/CMakeLists.txt
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2022-01-19 20:51:03 -0500
committerJune McEnroe <june@causal.agency>2022-01-19 20:51:03 -0500
commit74276efb806fb548dc2dff23b3c6526160172b04 (patch)
tree160bcae5d9825eaec751c0fb920b220710598120 /cards/CMakeLists.txt
parentReplace build system with cmake (diff)
parentReplace build system with cmake (diff)
downloadwep-74276efb806fb548dc2dff23b3c6526160172b04.tar.gz
wep-74276efb806fb548dc2dff23b3c6526160172b04.zip
Merge commit '344497630ac9ef2d46287cd574472ce369694076'
Diffstat (limited to '')
-rw-r--r--cards/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/cards/CMakeLists.txt b/cards/CMakeLists.txt
new file mode 100644
index 0000000..06ae91f
--- /dev/null
+++ b/cards/CMakeLists.txt
@@ -0,0 +1,18 @@
+cmake_minimum_required(VERSION 3.10)
+
+project(cards)
+
+find_package(SDL2 REQUIRED)
+
+if(NOT MSVC)
+	add_compile_options(-Wall -Wextra -pedantic)
+endif()
+
+add_library(cards STATIC cards.c)
+target_link_libraries(cards SDL2::SDL2)
+
+add_executable(example EXCLUDE_FROM_ALL example.c)
+target_link_libraries(example cards SDL2::SDL2main)
+
+add_executable(dump EXCLUDE_FROM_ALL dump.c)
+target_link_libraries(dump cards)