summary refs log tree commit diff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid S. Miller <davem@davemloft.net>2011-08-17 09:31:17 +0800
committerHerbert Xu <herbert@gondor.apana.org.au>2011-08-17 09:34:47 +0800
commit4da0e221ba2244921862d46cdeefbc8ab5808eed (patch)
tree929df8e803e84716319de3a1f94a085509bc652e /configure.ac
parent[ARITH] Avoid imaxdiv when only one of the results is wanted (diff)
downloaddash-4da0e221ba2244921862d46cdeefbc8ab5808eed.tar.gz
dash-4da0e221ba2244921862d46cdeefbc8ab5808eed.zip
[SHELL] Allow building without LINEO support
Simply specify --disable-lineno to configure.

Signed-off-by: David S. Miller <davem@davemloft.net>
Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5cd6e95..c6fb401 100644
--- a/configure.ac
+++ b/configure.ac
@@ -131,5 +131,10 @@ if test "$use_libedit" != "yes"; then
 else
 	export LIBS="$LIBS -ledit"
 fi
+AC_ARG_ENABLE(lineno, AS_HELP_STRING(--disable-lineno, \
+				     [Disable LINENO support]))
+if test "$enable_lineno" != "no"; then
+	AC_DEFINE([WITH_LINENO], 1, [Define if you build with -DWITH_LINENO])
+fi
 AC_CONFIG_FILES([Makefile src/Makefile])
 AC_OUTPUT