summary refs log tree commit diff
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2020-12-15 03:25:45 +0000
committerJune McEnroe <june@causal.agency>2020-12-15 03:25:45 +0000
commit1994f0f78fb8815fe7be2c109431a7b49b7b6053 (patch)
treec4b7cefa160c1f2a6b2cefe03ef062e661d98815
parentUpdate pounce to 2.1 (diff)
downloadports-1994f0f78fb8815fe7be2c109431a7b49b7b6053.tar.gz
ports-1994f0f78fb8815fe7be2c109431a7b49b7b6053.zip
Add imbox port
-rw-r--r--Makefile1
-rw-r--r--mail/imbox/Makefile29
-rw-r--r--mail/imbox/distinfo3
-rw-r--r--mail/imbox/pkg-descr5
4 files changed, 38 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 5e026af..22a1b03 100644
--- a/Makefile
+++ b/Makefile
@@ -6,6 +6,7 @@ PORTS += irc/litterbox
 PORTS += irc/pounce
 PORTS += irc/pounce-palaver
 PORTS += irc/scooper
+PORTS += mail/imbox
 PORTS += security/libretls
 PORTS += sysutils/catsit
 
diff --git a/mail/imbox/Makefile b/mail/imbox/Makefile
new file mode 100644
index 0000000..450d202
--- /dev/null
+++ b/mail/imbox/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME=	imbox
+DISTVERSION=	1.3
+CATEGORIES=	mail
+MASTER_SITES=	https://git.causal.agency/imbox/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	IMAP to mbox
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/git-fetch-email \
+		bin/imbox \
+		man/man1/git-fetch-email.1.gz \
+		man/man1/imbox.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/imbox
+
+.include <bsd.port.mk>
diff --git a/mail/imbox/distinfo b/mail/imbox/distinfo
new file mode 100644
index 0000000..3db47e6
--- /dev/null
+++ b/mail/imbox/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608002498
+SHA256 (imbox-1.3.tar.gz) = 8ef6e516f6958d3d157684a2106c4ba364de05e3076d2fddd8fda41fca00f9d6
+SIZE (imbox-1.3.tar.gz) = 22113
diff --git a/mail/imbox/pkg-descr b/mail/imbox/pkg-descr
new file mode 100644
index 0000000..76aa3e6
--- /dev/null
+++ b/mail/imbox/pkg-descr
@@ -0,0 +1,5 @@
+imbox is a small TLS-only IMAP client intended for applying git patches
+without need of any other mail client. It includes git-fetch-email, a
+wrapper modeled after git-send-email.
+
+WWW: https://git.causal.agency/imbox/