summary refs log tree commit diff
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2023-07-10 16:11:22 -0400
committerJune McEnroe <june@causal.agency>2023-07-10 16:11:22 -0400
commit1d519a192858ba47a3b5062916c1b22c7b6f55ee (patch)
tree38c2952e460c859a1ef56724b7f85fc82db80bd2
parentFreeBSD: Update litterbox to 1.9 (diff)
downloadports-1d519a192858ba47a3b5062916c1b22c7b6f55ee.tar.gz
ports-1d519a192858ba47a3b5062916c1b22c7b6f55ee.zip
OpenBSD: Add net/bubger
-rw-r--r--OpenBSD/net/bubger/Makefile30
-rw-r--r--OpenBSD/net/bubger/distinfo2
-rw-r--r--OpenBSD/net/bubger/pkg/DESCR4
-rw-r--r--OpenBSD/net/bubger/pkg/PLIST3
4 files changed, 39 insertions, 0 deletions
diff --git a/OpenBSD/net/bubger/Makefile b/OpenBSD/net/bubger/Makefile
new file mode 100644
index 0000000..d226626
--- /dev/null
+++ b/OpenBSD/net/bubger/Makefile
@@ -0,0 +1,30 @@
+COMMENT =	IMAP archive generator
+
+DISTNAME =	bubger-1.1
+
+CATEGORIES =	net
+
+HOMEPAGE =	https://git.causal.agency/bubger/about/
+
+MAINTAINER =	June McEnroe <june@causal.agency>
+
+# GPLv3+
+PERMIT_PACKAGE =	Yes
+
+# uses pledge() and unveil()
+WANTLIB += c tls
+LIB_DEPENDS =	converters/libiconv
+
+MASTER_SITES =		https://git.causal.agency/bubger/snapshot/
+
+# C11
+COMPILER =		base-clang ports-gcc
+COMPILER_LANGS =	c
+
+FAKE_FLAGS =		PREFIX=${TRUEPREFIX}
+
+CONFIGURE_STYLE =	simple
+
+NO_TEST =		Yes
+
+.include <bsd.port.mk>
diff --git a/OpenBSD/net/bubger/distinfo b/OpenBSD/net/bubger/distinfo
new file mode 100644
index 0000000..fb1a071
--- /dev/null
+++ b/OpenBSD/net/bubger/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bubger-1.1.tar.gz) = hnt8BVougThOm83NEuzzjA54iR6XaLaXh1VH4M5NmQQ=
+SIZE (bubger-1.1.tar.gz) = 38573
diff --git a/OpenBSD/net/bubger/pkg/DESCR b/OpenBSD/net/bubger/pkg/DESCR
new file mode 100644
index 0000000..fb62e9f
--- /dev/null
+++ b/OpenBSD/net/bubger/pkg/DESCR
@@ -0,0 +1,4 @@
+bubger is a mailing list archive generator for mail stored in IMAP.
+It produces static files of HTML, Atom and mboxrd, making its output
+easy to serve from a host without IMAP access.  It requires the
+IMAP THREAD extension.
diff --git a/OpenBSD/net/bubger/pkg/PLIST b/OpenBSD/net/bubger/pkg/PLIST
new file mode 100644
index 0000000..2803d1c
--- /dev/null
+++ b/OpenBSD/net/bubger/pkg/PLIST
@@ -0,0 +1,3 @@
+@comment $OpenBSD: PLIST,v$
+@bin bin/bubger
+@man man/man1/bubger.1