summary refs log tree commit diff
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2020-08-10 16:29:01 +0000
committerJune McEnroe <june@causal.agency>2020-08-10 16:29:01 +0000
commit4cd92f7de83f8992cfd210d4d1dffca620089a45 (patch)
tree741c1cba7b270e306a2132a23701762bd5f8d7c6
parentAdd missing USES=pkgconfig to pounce (diff)
downloadports-4cd92f7de83f8992cfd210d4d1dffca620089a45.tar.gz
ports-4cd92f7de83f8992cfd210d4d1dffca620089a45.zip
Add litterbox port
-rw-r--r--Makefile1
-rw-r--r--irc/litterbox/Makefile35
-rw-r--r--irc/litterbox/distinfo3
-rw-r--r--irc/litterbox/pkg-descr4
4 files changed, 43 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 9cd00db..de0583b 100644
--- a/Makefile
+++ b/Makefile
@@ -2,6 +2,7 @@ PORTSDIR = /usr/ports
 
 PORTS += devel/cgit-patched
 PORTS += irc/catgirl
+PORTS += irc/litterbox
 PORTS += irc/pounce
 PORTS += security/libretls
 
diff --git a/irc/litterbox/Makefile b/irc/litterbox/Makefile
new file mode 100644
index 0000000..d41308a
--- /dev/null
+++ b/irc/litterbox/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME=	litterbox
+DISTVERSION=	1.5
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/litterbox/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Full-text search IRC logger
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libsqlite3.so:databases/sqlite3 \
+		libtls.so:security/libretls
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/litterbox \
+		bin/scoop \
+		bin/unscoop \
+		etc/rc.d/litterbox \
+		man/man1/litterbox.1.gz \
+		man/man1/scoop.1.gz \
+		man/man1/unscoop.1.gz
+
+post-install:
+.for b in litterbox scoop unscoop
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${b}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/irc/litterbox/distinfo b/irc/litterbox/distinfo
new file mode 100644
index 0000000..7b61804
--- /dev/null
+++ b/irc/litterbox/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1597076610
+SHA256 (litterbox-1.5.tar.gz) = 2013086e40d86e9b1133c422c5524595c735f2a2b06691091f1e1cd281641ec1
+SIZE (litterbox-1.5.tar.gz) = 36552
diff --git a/irc/litterbox/pkg-descr b/irc/litterbox/pkg-descr
new file mode 100644
index 0000000..aed1c16
--- /dev/null
+++ b/irc/litterbox/pkg-descr
@@ -0,0 +1,4 @@
+litterbox is a TLS-only IRC logger with full-text search provided by
+SQLite3. It can be used as a logging bot or with the IRC bouncer pounce.
+
+WWW: https://git.causal.agency/litterbox/