summary refs log tree commit diff
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2020-08-23 19:28:45 +0000
committerJune McEnroe <june@causal.agency>2020-08-23 19:28:45 +0000
commit89e3ffdeded210fd49f19f93af2f73d58f523b5d (patch)
tree89514e343579533c0100240ceea6e639de392d22
parentAdd catsit port (diff)
downloadports-89e3ffdeded210fd49f19f93af2f73d58f523b5d.tar.gz
ports-89e3ffdeded210fd49f19f93af2f73d58f523b5d.zip
Add scooper port
-rw-r--r--Makefile1
-rw-r--r--irc/scooper/Makefile29
-rw-r--r--irc/scooper/distinfo3
-rw-r--r--irc/scooper/pkg-descr4
4 files changed, 37 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 0ba9ff5..b9b5c3b 100644
--- a/Makefile
+++ b/Makefile
@@ -4,6 +4,7 @@ PORTS += devel/cgit-patched
 PORTS += irc/catgirl
 PORTS += irc/litterbox
 PORTS += irc/pounce
+PORTS += irc/scooper
 PORTS += security/libretls
 PORTS += sysutils/catsit
 
diff --git a/irc/scooper/Makefile b/irc/scooper/Makefile
new file mode 100644
index 0000000..f53c714
--- /dev/null
+++ b/irc/scooper/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME=	scooper
+DISTVERSION=	1.0
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/scooper/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Web interface for litterbox
+
+LICENSE=	AGPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+BUILD_DEPENDS=	${LOCALBASE}/lib/libkcgi.a:www/kcgi \
+		${LOCALBASE}/lib/libkcgihtml.a:www/kcgi \
+		${LOCALBASE}/lib/libsqlite3.a:databases/sqlite3
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/scooper \
+		man/man1/scooper.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/scooper
+
+.include <bsd.port.mk>
diff --git a/irc/scooper/distinfo b/irc/scooper/distinfo
new file mode 100644
index 0000000..d9b0167
--- /dev/null
+++ b/irc/scooper/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1598210718
+SHA256 (scooper-1.0.tar.gz) = b995b5a0b4e33661993efb44e0702749c247e7d3ea727ba2ad886a8e5218efee
+SIZE (scooper-1.0.tar.gz) = 26835
diff --git a/irc/scooper/pkg-descr b/irc/scooper/pkg-descr
new file mode 100644
index 0000000..830091a
--- /dev/null
+++ b/irc/scooper/pkg-descr
@@ -0,0 +1,4 @@
+scooper is a CGI and FastCGI web interface for the litterbox IRC logger.
+It provides IRC log listings and full-text search.
+
+WWW: https://git.causal.agency/scooper/