summary refs log tree commit diff
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2021-03-08 23:36:03 +0000
committerJune McEnroe <june@causal.agency>2021-03-08 23:36:03 +0000
commita44e20f4b39843b7fb3449dcddb1238bb2bde77f (patch)
treeab93076d847f3804d1942d7ece30e55387d881f6
parentUpdate catsit to 1.3 (diff)
downloadports-a44e20f4b39843b7fb3449dcddb1238bb2bde77f.tar.gz
ports-a44e20f4b39843b7fb3449dcddb1238bb2bde77f.zip
Add bubger port
-rw-r--r--Makefile1
-rw-r--r--mail/bubger/Makefile29
-rw-r--r--mail/bubger/distinfo3
-rw-r--r--mail/bubger/pkg-descr6
4 files changed, 39 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index d3bcbc6..ed04b2b 100644
--- a/Makefile
+++ b/Makefile
@@ -6,6 +6,7 @@ PORTS += irc/litterbox
 PORTS += irc/pounce
 PORTS += irc/pounce-palaver
 PORTS += irc/scooper
+PORTS += mail/bubger
 PORTS += mail/imbox
 PORTS += mail/notemap
 PORTS += security/libretls
diff --git a/mail/bubger/Makefile b/mail/bubger/Makefile
new file mode 100644
index 0000000..05e9033
--- /dev/null
+++ b/mail/bubger/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME=	bubger
+DISTVERSION=	1.0
+CATEGORIES=	mail
+MASTER_SITES=	https://git.causal.agency/bubger/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	IMAP archive generator
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	iconv pkgconfig
+CFLAGS+=	-I${ICONV_PREFIX}/include
+LDFLAGS+=	-L${ICONV_PREFIX}/lib ${ICONV_LIB}
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/bubger \
+		man/man1/bubger.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/bubger
+
+.include <bsd.port.mk>
diff --git a/mail/bubger/distinfo b/mail/bubger/distinfo
new file mode 100644
index 0000000..b13bde1
--- /dev/null
+++ b/mail/bubger/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1615246395
+SHA256 (bubger-1.0.tar.gz) = fa23e4e77fd2bee442ce3873391f3d7c408785df287b64d8e290b045bfc84cf8
+SIZE (bubger-1.0.tar.gz) = 36723
diff --git a/mail/bubger/pkg-descr b/mail/bubger/pkg-descr
new file mode 100644
index 0000000..1532b98
--- /dev/null
+++ b/mail/bubger/pkg-descr
@@ -0,0 +1,6 @@
+bubger is a mailing list archive generator for mail stored in IMAP.
+It produces static files of HTML, Atom and mboxrd, making its output
+easy to serve from a host without IMAP access. It requires the IMAP
+THREAD extension.
+
+WWW: https://git.causal.agency/bubger/