summary refs log tree commit diff
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2020-12-18 23:16:18 +0000
committerJune McEnroe <june@causal.agency>2020-12-18 23:16:18 +0000
commitb71add28ab49b0dea763924a0bc0df0686d9e1a0 (patch)
tree42cd3e8142613cef59bad04a42a5bd092f8d7be0
parentUpdate libretls to 3.3.1 (diff)
downloadports-b71add28ab49b0dea763924a0bc0df0686d9e1a0.tar.gz
ports-b71add28ab49b0dea763924a0bc0df0686d9e1a0.zip
Add notemap port
-rw-r--r--Makefile1
-rw-r--r--mail/notemap/Makefile29
-rw-r--r--mail/notemap/distinfo3
-rw-r--r--mail/notemap/pkg-descr4
4 files changed, 37 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 22a1b03..b80e429 100644
--- a/Makefile
+++ b/Makefile
@@ -7,6 +7,7 @@ PORTS += irc/pounce
 PORTS += irc/pounce-palaver
 PORTS += irc/scooper
 PORTS += mail/imbox
+PORTS += mail/notemap
 PORTS += security/libretls
 PORTS += sysutils/catsit
 
diff --git a/mail/notemap/Makefile b/mail/notemap/Makefile
new file mode 100644
index 0000000..d5d9dd0
--- /dev/null
+++ b/mail/notemap/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME=	notemap
+DISTVERSION=	1.3
+CATEGORIES=	mail
+MASTER_SITES=	https://git.causal.agency/notemap/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	mirror notes to IMAP
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/git-notemap \
+		bin/notemap \
+		man/man1/git-notemap.1.gz \
+		man/man1/notemap.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/notemap
+
+.include <bsd.port.mk>
diff --git a/mail/notemap/distinfo b/mail/notemap/distinfo
new file mode 100644
index 0000000..135e1c3
--- /dev/null
+++ b/mail/notemap/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608333183
+SHA256 (notemap-1.3.tar.gz) = 76f9f44963546d443420f03159d6bebfd4d661a67dd8e4e59ccde5d23f51c68d
+SIZE (notemap-1.3.tar.gz) = 22773
diff --git a/mail/notemap/pkg-descr b/mail/notemap/pkg-descr
new file mode 100644
index 0000000..67622a8
--- /dev/null
+++ b/mail/notemap/pkg-descr
@@ -0,0 +1,4 @@
+notemap mirrors text files to an IMAP mailbox in a format compatible
+with the iOS Notes app.
+
+WWW: https://git.causal.agency/notemap/