summary refs log tree commit diff
path: root/OpenBSD/net/pounce-palaver/Makefile
diff options
context:
space:
mode:
authorKusoneko <kusoneko@kusoneko.moe>2024-03-20 22:34:02 -0400
committerJune McEnroe <june@causal.agency>2024-03-21 21:23:29 -0400
commit30e471ef67898fff3d8b93168b27b9b760b2e897 (patch)
tree802c7e8cafbc747497fd3c19906c6b6856986e9c /OpenBSD/net/pounce-palaver/Makefile
parentOpenBSD: Add net/bubger (diff)
downloadports-master.tar.gz
ports-master.zip
OpenBSD: switch ports MASTER_SITES=>SITES for 7.4 HEAD master
As of OpenBSD 7.4, ports give errors when using the following paradigm:
```
DISTFILES = file.ext:0 file2.ext:1
MASTER_SITES0 = https://asite.com/path/to/file.ext
MASTER_SITES1 = https://anothersite.com/path/to/file2.ext
```

Instead, ports now use the following:
```
DISTFILES = file.ext
DISTFILES.substring = file2.ext
SITES = https://asite.com/path/to/file.ext
SITES.substring = https://anothersite.com/path/to/file2.ext
```

This changes all the OpenBSD ports to the new paradigm, allowing them to
compile on OpenBSD 7.4+.

Note: some OpenBSD ports are not currently up to date with upstream:
- cgit-pink uses git 2.36.1 when the latest git release is 2.44.0 as of now
- litterbox is at version 1.8 instead of 1.9
- pounce* are at version 3.0 instead of 3.1
- offers catsit instead of kitd

Signed-off-by: Kusoneko <kusoneko@kusoneko.moe>
Diffstat (limited to 'OpenBSD/net/pounce-palaver/Makefile')
-rw-r--r--OpenBSD/net/pounce-palaver/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/OpenBSD/net/pounce-palaver/Makefile b/OpenBSD/net/pounce-palaver/Makefile
index f7c10a2..e3e9d8f 100644
--- a/OpenBSD/net/pounce-palaver/Makefile
+++ b/OpenBSD/net/pounce-palaver/Makefile
@@ -16,7 +16,7 @@ PERMIT_PACKAGE =	Yes
 # uses pledge() and unveil()
 WANTLIB += c curl sqlite3 tls
 
-MASTER_SITES =		https://git.causal.agency/pounce/snapshot/
+SITES =		https://git.causal.agency/pounce/snapshot/
 
 # C11
 COMPILER =		base-clang ports-gcc
7e8ab6efaf4162aeaeb716e7f&follow=1'>Clarify /window documentationJune McEnroe 2019-02-23Use first word of params in input commandsJune McEnroe 2019-02-23Add C-n and C-p key bindings to switch windowsJune McEnroe 2019-02-23Change example command to join #ascii.town on freenodeJune McEnroe 2019-02-23Call def_prog_mode after termNoFlowJune McEnroe 2019-02-22Move IRC formatting reset to C-sJune McEnroe 2019-02-22Disable terminal flow controlJune McEnroe 2019-02-22Bind up and down arrows to scrollJune McEnroe 2019-02-22Remove topic TODOJune McEnroe 2019-02-22Add /znc commandJune McEnroe 2019-02-22Update status line after scrolling and term eventsJune McEnroe 2019-02-22Reorganize input.cJune McEnroe 2019-02-22Fix name of <raw> window in man pageJune McEnroe 2019-02-22Rename global tags with angle bracketsJune McEnroe 2019-02-22Show status window while connectingJune McEnroe 2019-02-22Reorganize UI code for the umpteenth timeJune McEnroe 2019-02-21Replace "view" with "window"June McEnroe 2019-02-21Remove ROT13June McEnroe 2019-02-21Clean up man pageJune McEnroe 2019-01-26Draw UI before connectingJune McEnroe 2019-01-25Avoid unused variable warnings with getyxJune McEnroe 2019-01-25Add GNU/Linux build instructionsJune McEnroe