summary refs log tree commit diff
path: root/OpenBSD/www/cgit-pink/Makefile
diff options
context:
space:
mode:
authorKusoneko <kusoneko@kusoneko.moe>2024-03-20 22:34:02 -0400
committerJune McEnroe <june@causal.agency>2024-03-21 21:23:29 -0400
commit30e471ef67898fff3d8b93168b27b9b760b2e897 (patch)
tree802c7e8cafbc747497fd3c19906c6b6856986e9c /OpenBSD/www/cgit-pink/Makefile
parentOpenBSD: Add net/bubger (diff)
downloadports-master.tar.gz
ports-master.zip
OpenBSD: switch ports MASTER_SITES=>SITES for 7.4 HEAD master
As of OpenBSD 7.4, ports give errors when using the following paradigm:
```
DISTFILES = file.ext:0 file2.ext:1
MASTER_SITES0 = https://asite.com/path/to/file.ext
MASTER_SITES1 = https://anothersite.com/path/to/file2.ext
```

Instead, ports now use the following:
```
DISTFILES = file.ext
DISTFILES.substring = file2.ext
SITES = https://asite.com/path/to/file.ext
SITES.substring = https://anothersite.com/path/to/file2.ext
```

This changes all the OpenBSD ports to the new paradigm, allowing them to
compile on OpenBSD 7.4+.

Note: some OpenBSD ports are not currently up to date with upstream:
- cgit-pink uses git 2.36.1 when the latest git release is 2.44.0 as of now
- litterbox is at version 1.8 instead of 1.9
- pounce* are at version 3.0 instead of 3.1
- offers catsit instead of kitd

Signed-off-by: Kusoneko <kusoneko@kusoneko.moe>
Diffstat (limited to 'OpenBSD/www/cgit-pink/Makefile')
-rw-r--r--OpenBSD/www/cgit-pink/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/OpenBSD/www/cgit-pink/Makefile b/OpenBSD/www/cgit-pink/Makefile
index c547c07..1eb163b 100644
--- a/OpenBSD/www/cgit-pink/Makefile
+++ b/OpenBSD/www/cgit-pink/Makefile
@@ -5,11 +5,11 @@ COMMENT =	web frontend for git repositories
 DISTNAME =	cgit-pink-1.4.1
 CATEGORIES =	www devel
 
-DISTFILES =	${DISTNAME}.tar.gz:0 \
-		git-2.36.1.tar.gz:1
+DISTFILES =	${DISTNAME}.tar.gz
+DISTFILES.git = git-2.36.1.tar.gz
 
-MASTER_SITES0 =		https://git.causal.agency/cgit-pink/snapshot/
-MASTER_SITES1 =		https://www.kernel.org/pub/software/scm/git/
+SITES =		https://git.causal.agency/cgit-pink/snapshot/
+SITES.git =		https://www.kernel.org/pub/software/scm/git/
 HOMEPAGE =		https://git.causal.agency/cgit-pink/about/
 
 # GPLv2