summary refs log tree commit diff
path: root/devel/cgit-causal-agency/Makefile
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2021-09-30 19:12:10 +0000
committerJune McEnroe <june@causal.agency>2021-09-30 19:12:10 +0000
commit97eb0074b135b2636d84ff503988e3d76803ddcc (patch)
treeb7bf84cab6a5df4035634f60e4b92ed8dbcf8c32 /devel/cgit-causal-agency/Makefile
parentUpdate catsit to 1.4 (diff)
downloadports-97eb0074b135b2636d84ff503988e3d76803ddcc.tar.gz
ports-97eb0074b135b2636d84ff503988e3d76803ddcc.zip
Move FreeBSD ports under FreeBSD directory
Diffstat (limited to 'devel/cgit-causal-agency/Makefile')
-rw-r--r--devel/cgit-causal-agency/Makefile71
1 files changed, 0 insertions, 71 deletions
diff --git a/devel/cgit-causal-agency/Makefile b/devel/cgit-causal-agency/Makefile
deleted file mode 100644
index be15f90..0000000
--- a/devel/cgit-causal-agency/Makefile
+++ /dev/null
@@ -1,71 +0,0 @@
-PORTNAME=	cgit-causal-agency
-PORTVERSION=	20210922
-CONFLICTS_INSTALL=	cgit
-CATEGORIES=	devel www
-MASTER_SITES=	https://git.causal.agency/src/snapshot/:src \
-		KERNEL_ORG/software/scm/git:git
-DISTFILES=	src-${SRC_VERSION}${EXTRACT_SUFX}:src \
-		git-${GIT_VERSION}${EXTRACT_SUFX}:git
-DISTNAME=	src-${SRC_VERSION}
-
-MAINTAINER=	june@causal.agency
-COMMENT=	Fast, lightweight web frontend for Git repositories
-
-LICENSE=	GPLv2
-LICENSE_FILE=	${WRKSRC}/COPYING
-
-TEST_DEPENDS=	msgfmt:devel/gettext-tools
-
-SRC_VERSION=	5a8f6f3698fbd69b97483c7b84bf661f4761124f
-GIT_VERSION=	2.32.0
-WRKSRC_SUBDIR=	www/git.causal.agency/cgit
-
-USES=		cpe gmake iconv perl5 python:3.2+,env shebangfix ssl
-CPE_VENDOR=	lars_hjemli
-USE_PERL5=	test
-SHEBANG_FILES=	filters/email-gravatar.py \
-		filters/html-converters/md2html \
-		filters/html-converters/rst2html \
-		filters/syntax-highlighting.py
-WWWDIR=	${PREFIX}/www/cgit
-
-CFLAGS+=	-I${LOCALBASE}/include
-LDFLAGS+=	-L${LOCALBASE}/lib ${ICONV_LIB}
-MAKE_ARGS+=	CGIT_SCRIPT_PATH=${WWWDIR} CGIT_CONFIG=${PREFIX}/etc/cgitrc \
-		prefix=${PREFIX} NO_GETTEXT=1 NO_R_TO_GCC_LINKER=1 V=1
-
-SUB_FILES=	pkg-message
-
-PORTDOCS=	cgitrc.5.txt
-
-OPTIONS_DEFINE=	DOCS ASCIIDOC
-OPTIONS_DEFAULT=	ASCIIDOC
-OPTIONS_SUB=	yes
-
-ASCIIDOC_DESC=	Use asciidoc to preprocess man page
-ASCIIDOC_BUILD_DEPENDS=	a2x:textproc/asciidoc
-
-post-extract:
-	@${MV} ${WRKDIR}/git-${GIT_VERSION} ${WRKSRC}/git
-
-post-patch:
-	@${REINPLACE_CMD} -e 's/^\(GIT_VER =\).*$$/\1 ${GIT_VERSION}/' \
-		${WRKSRC}/Makefile
-
-	@${REINPLACE_CMD} -e 's/-liconv/${ICONV_LIB}/' \
-		-e "s|\(ALL_CFLAGS =\)|\1 -I${OPENSSLINC}|g" \
-		-e "s|\(ALL_LDFLAGS =\)|\1 -L${OPENSSLLIB}|g" \
-		${WRKSRC}/git/Makefile
-
-post-install:
-	${STRIP_CMD} ${STAGEDIR}${WWWDIR}/cgit.cgi
-
-post-install-DOCS-on:
-	@${MKDIR} ${STAGEDIR}${DOCSDIR}
-	${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-
-post-install-ASCIIDOC-on:
-	a2x --doctype manpage --format manpage ${WRKSRC}/cgitrc.5.txt
-	${INSTALL_MAN} ${WRKSRC}/cgitrc.5 ${STAGEDIR}${PREFIX}/man/man5
-
-.include <bsd.port.mk>