summary refs log tree commit diff
path: root/security
diff options
context:
space:
mode:
authorJune McEnroe <june@causal.agency>2020-08-06 20:09:34 +0000
committerJune McEnroe <june@causal.agency>2020-08-06 20:09:34 +0000
commite3c5c188010d9bb117869cd8bda6efbb7f6d1ddb (patch)
treeeb1550772dcd7257cd13c92bcaf380db2fcb70dc /security
parentAdd cgit-patched port (diff)
downloadports-e3c5c188010d9bb117869cd8bda6efbb7f6d1ddb.tar.gz
ports-e3c5c188010d9bb117869cd8bda6efbb7f6d1ddb.zip
Add libretls port
Based on libressl port.
Diffstat (limited to 'security')
-rw-r--r--security/libretls/Makefile28
-rw-r--r--security/libretls/distinfo3
-rw-r--r--security/libretls/pkg-descr4
-rw-r--r--security/libretls/pkg-plist94
4 files changed, 129 insertions, 0 deletions
diff --git a/security/libretls/Makefile b/security/libretls/Makefile
new file mode 100644
index 0000000..4d4a83a
--- /dev/null
+++ b/security/libretls/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME=	libretls
+PORTVERSION=	3.2.0
+CATEGORIES=	security devel
+MASTER_SITES=	https://causal.agency/libretls/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Port of libtls for OpenSSL
+
+LICENSE=	ISCL
+
+BROKEN_SSL=			libressl
+BROKEN_SSL_REASON_libressl=	libtls is provided by LibreSSL
+
+USES=		libtool pathfix pkgconfig ssl
+USE_LDCONFIG=	yes
+GNU_CONFIGURE=	yes
+CONFIGURE_ARGS+=	--with-openssl=${OPENSSLBASE}
+CFLAGS+=	-fpic -DPIC -Wl,-rpath,${PREFIX}/lib -Wl,--as-needed
+LDFLAGS+=	-pthread
+
+CONFLICTS_INSTALL=	libressl-[0-9]* \
+			libressl-devel-[0-9]*
+
+INSTALL_TARGET=		install-strip
+
+.include <bsd.port.mk>
diff --git a/security/libretls/distinfo b/security/libretls/distinfo
new file mode 100644
index 0000000..0c4ba35
--- /dev/null
+++ b/security/libretls/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1596744021
+SHA256 (libretls-3.2.0.tar.gz) = 6b83c48569a93bd2a01fbbd8f7287698c95942d0d5542bb04c1a1329f12deb30
+SIZE (libretls-3.2.0.tar.gz) = 424807
diff --git a/security/libretls/pkg-descr b/security/libretls/pkg-descr
new file mode 100644
index 0000000..6d3a7ef
--- /dev/null
+++ b/security/libretls/pkg-descr
@@ -0,0 +1,4 @@
+LibreTLS is a port of libtls from LibreSSL to OpenSSL. libtls is a new TLS
+library, designed to make it easier to write foolproof applications.
+
+WWW: https://git.causal.agency/libretls/about
diff --git a/security/libretls/pkg-plist b/security/libretls/pkg-plist
new file mode 100644
index 0000000..1330004
--- /dev/null
+++ b/security/libretls/pkg-plist
@@ -0,0 +1,94 @@
+include/tls.h
+lib/libtls.a
+lib/libtls.so
+lib/libtls.so.20
+lib/libtls.so.20.0.1
+libdata/pkgconfig/libtls.pc
+man/man3/tls_accept_cbs.3.gz
+man/man3/tls_accept_fds.3.gz
+man/man3/tls_accept_socket.3.gz
+man/man3/tls_client.3.gz
+man/man3/tls_close.3.gz
+man/man3/tls_config_add_keypair_file.3.gz
+man/man3/tls_config_add_keypair_mem.3.gz
+man/man3/tls_config_add_keypair_ocsp_file.3.gz
+man/man3/tls_config_add_keypair_ocsp_mem.3.gz
+man/man3/tls_config_add_ticket_key.3.gz
+man/man3/tls_config_clear_keys.3.gz
+man/man3/tls_config_error.3.gz
+man/man3/tls_config_free.3.gz
+man/man3/tls_config_insecure_noverifycert.3.gz
+man/man3/tls_config_insecure_noverifyname.3.gz
+man/man3/tls_config_insecure_noverifytime.3.gz
+man/man3/tls_config_new.3.gz
+man/man3/tls_config_ocsp_require_stapling.3.gz
+man/man3/tls_config_parse_protocols.3.gz
+man/man3/tls_config_prefer_ciphers_client.3.gz
+man/man3/tls_config_prefer_ciphers_server.3.gz
+man/man3/tls_config_set_alpn.3.gz
+man/man3/tls_config_set_ca_file.3.gz
+man/man3/tls_config_set_ca_mem.3.gz
+man/man3/tls_config_set_ca_path.3.gz
+man/man3/tls_config_set_cert_file.3.gz
+man/man3/tls_config_set_cert_mem.3.gz
+man/man3/tls_config_set_ciphers.3.gz
+man/man3/tls_config_set_crl_file.3.gz
+man/man3/tls_config_set_crl_mem.3.gz
+man/man3/tls_config_set_dheparams.3.gz
+man/man3/tls_config_set_ecdhecurves.3.gz
+man/man3/tls_config_set_key_file.3.gz
+man/man3/tls_config_set_key_mem.3.gz
+man/man3/tls_config_set_keypair_file.3.gz
+man/man3/tls_config_set_keypair_mem.3.gz
+man/man3/tls_config_set_keypair_ocsp_file.3.gz
+man/man3/tls_config_set_keypair_ocsp_mem.3.gz
+man/man3/tls_config_set_ocsp_staple_file.3.gz
+man/man3/tls_config_set_ocsp_staple_mem.3.gz
+man/man3/tls_config_set_protocols.3.gz
+man/man3/tls_config_set_session_fd.3.gz
+man/man3/tls_config_set_session_id.3.gz
+man/man3/tls_config_set_session_lifetime.3.gz
+man/man3/tls_config_set_verify_depth.3.gz
+man/man3/tls_config_verify.3.gz
+man/man3/tls_config_verify_client.3.gz
+man/man3/tls_config_verify_client_optional.3.gz
+man/man3/tls_configure.3.gz
+man/man3/tls_conn_alpn_selected.3.gz
+man/man3/tls_conn_cipher.3.gz
+man/man3/tls_conn_cipher_strength.3.gz
+man/man3/tls_conn_servername.3.gz
+man/man3/tls_conn_session_resumed.3.gz
+man/man3/tls_conn_version.3.gz
+man/man3/tls_connect.3.gz
+man/man3/tls_connect_cbs.3.gz
+man/man3/tls_connect_fds.3.gz
+man/man3/tls_connect_servername.3.gz
+man/man3/tls_connect_socket.3.gz
+man/man3/tls_default_ca_cert_file.3.gz
+man/man3/tls_error.3.gz
+man/man3/tls_free.3.gz
+man/man3/tls_handshake.3.gz
+man/man3/tls_init.3.gz
+man/man3/tls_load_file.3.gz
+man/man3/tls_ocsp_process_response.3.gz
+man/man3/tls_peer_cert_chain_pem.3.gz
+man/man3/tls_peer_cert_contains_name.3.gz
+man/man3/tls_peer_cert_hash.3.gz
+man/man3/tls_peer_cert_issuer.3.gz
+man/man3/tls_peer_cert_notafter.3.gz
+man/man3/tls_peer_cert_notbefore.3.gz
+man/man3/tls_peer_cert_provided.3.gz
+man/man3/tls_peer_cert_subject.3.gz
+man/man3/tls_peer_ocsp_cert_status.3.gz
+man/man3/tls_peer_ocsp_crl_reason.3.gz
+man/man3/tls_peer_ocsp_next_update.3.gz
+man/man3/tls_peer_ocsp_response_status.3.gz
+man/man3/tls_peer_ocsp_result.3.gz
+man/man3/tls_peer_ocsp_revocation_time.3.gz
+man/man3/tls_peer_ocsp_this_update.3.gz
+man/man3/tls_peer_ocsp_url.3.gz
+man/man3/tls_read.3.gz
+man/man3/tls_reset.3.gz
+man/man3/tls_server.3.gz
+man/man3/tls_unload_file.3.gz
+man/man3/tls_write.3.gz