summary refs log tree commit diff
path: root/FreeBSD/devel
diff options
context:
space:
mode:
Diffstat (limited to 'FreeBSD/devel')
-rw-r--r--FreeBSD/devel/cgit-causal-agency/Makefile71
-rw-r--r--FreeBSD/devel/cgit-causal-agency/distinfo5
-rw-r--r--FreeBSD/devel/cgit-causal-agency/files/pkg-message.in18
-rw-r--r--FreeBSD/devel/cgit-causal-agency/pkg-descr4
-rw-r--r--FreeBSD/devel/cgit-causal-agency/pkg-plist14
5 files changed, 112 insertions, 0 deletions
diff --git a/FreeBSD/devel/cgit-causal-agency/Makefile b/FreeBSD/devel/cgit-causal-agency/Makefile
new file mode 100644
index 0000000..be15f90
--- /dev/null
+++ b/FreeBSD/devel/cgit-causal-agency/Makefile
@@ -0,0 +1,71 @@
+PORTNAME=	cgit-causal-agency
+PORTVERSION=	20210922
+CONFLICTS_INSTALL=	cgit
+CATEGORIES=	devel www
+MASTER_SITES=	https://git.causal.agency/src/snapshot/:src \
+		KERNEL_ORG/software/scm/git:git
+DISTFILES=	src-${SRC_VERSION}${EXTRACT_SUFX}:src \
+		git-${GIT_VERSION}${EXTRACT_SUFX}:git
+DISTNAME=	src-${SRC_VERSION}
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Fast, lightweight web frontend for Git repositories
+
+LICENSE=	GPLv2
+LICENSE_FILE=	${WRKSRC}/COPYING
+
+TEST_DEPENDS=	msgfmt:devel/gettext-tools
+
+SRC_VERSION=	5a8f6f3698fbd69b97483c7b84bf661f4761124f
+GIT_VERSION=	2.32.0
+WRKSRC_SUBDIR=	www/git.causal.agency/cgit
+
+USES=		cpe gmake iconv perl5 python:3.2+,env shebangfix ssl
+CPE_VENDOR=	lars_hjemli
+USE_PERL5=	test
+SHEBANG_FILES=	filters/email-gravatar.py \
+		filters/html-converters/md2html \
+		filters/html-converters/rst2html \
+		filters/syntax-highlighting.py
+WWWDIR=	${PREFIX}/www/cgit
+
+CFLAGS+=	-I${LOCALBASE}/include
+LDFLAGS+=	-L${LOCALBASE}/lib ${ICONV_LIB}
+MAKE_ARGS+=	CGIT_SCRIPT_PATH=${WWWDIR} CGIT_CONFIG=${PREFIX}/etc/cgitrc \
+		prefix=${PREFIX} NO_GETTEXT=1 NO_R_TO_GCC_LINKER=1 V=1
+
+SUB_FILES=	pkg-message
+
+PORTDOCS=	cgitrc.5.txt
+
+OPTIONS_DEFINE=	DOCS ASCIIDOC
+OPTIONS_DEFAULT=	ASCIIDOC
+OPTIONS_SUB=	yes
+
+ASCIIDOC_DESC=	Use asciidoc to preprocess man page
+ASCIIDOC_BUILD_DEPENDS=	a2x:textproc/asciidoc
+
+post-extract:
+	@${MV} ${WRKDIR}/git-${GIT_VERSION} ${WRKSRC}/git
+
+post-patch:
+	@${REINPLACE_CMD} -e 's/^\(GIT_VER =\).*$$/\1 ${GIT_VERSION}/' \
+		${WRKSRC}/Makefile
+
+	@${REINPLACE_CMD} -e 's/-liconv/${ICONV_LIB}/' \
+		-e "s|\(ALL_CFLAGS =\)|\1 -I${OPENSSLINC}|g" \
+		-e "s|\(ALL_LDFLAGS =\)|\1 -L${OPENSSLLIB}|g" \
+		${WRKSRC}/git/Makefile
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${WWWDIR}/cgit.cgi
+
+post-install-DOCS-on:
+	@${MKDIR} ${STAGEDIR}${DOCSDIR}
+	${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+post-install-ASCIIDOC-on:
+	a2x --doctype manpage --format manpage ${WRKSRC}/cgitrc.5.txt
+	${INSTALL_MAN} ${WRKSRC}/cgitrc.5 ${STAGEDIR}${PREFIX}/man/man5
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/devel/cgit-causal-agency/distinfo b/FreeBSD/devel/cgit-causal-agency/distinfo
new file mode 100644
index 0000000..6397e05
--- /dev/null
+++ b/FreeBSD/devel/cgit-causal-agency/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1632325421
+SHA256 (src-5a8f6f3698fbd69b97483c7b84bf661f4761124f.tar.gz) = f86404c02707dedbeba82bee3316b0c44a6d847b5c4a584bc5d0d20cc4528345
+SIZE (src-5a8f6f3698fbd69b97483c7b84bf661f4761124f.tar.gz) = 899773
+SHA256 (git-2.32.0.tar.gz) = 6038f06d396ba9dab2eee541c7db6e7f9f847f181ec62f3d8441893f8c469398
+SIZE (git-2.32.0.tar.gz) = 10321570
diff --git a/FreeBSD/devel/cgit-causal-agency/files/pkg-message.in b/FreeBSD/devel/cgit-causal-agency/files/pkg-message.in
new file mode 100644
index 0000000..0190639
--- /dev/null
+++ b/FreeBSD/devel/cgit-causal-agency/files/pkg-message.in
@@ -0,0 +1,18 @@
+[
+{ type: install
+  message: <<EOM
+cgit has been successfully installed.
+
+To enable cgit in Apache, use something like the following:
+
+  <Directory "%%WWWDIR%%/">
+      AllowOverride None
+      Options +ExecCGI
+      Require all granted 
+  </Directory>
+
+Documentation and sample configuration can be found
+in %%DOCSDIR%%/cgitrc.5.txt.
+EOM
+}
+]
diff --git a/FreeBSD/devel/cgit-causal-agency/pkg-descr b/FreeBSD/devel/cgit-causal-agency/pkg-descr
new file mode 100644
index 0000000..1a9d828
--- /dev/null
+++ b/FreeBSD/devel/cgit-causal-agency/pkg-descr
@@ -0,0 +1,4 @@
+cgit is a fast web interface for the Git SCM, using a built-in cache to
+decrease server I/O pressure.
+
+WWW: https://git.zx2c4.com/cgit/about/
diff --git a/FreeBSD/devel/cgit-causal-agency/pkg-plist b/FreeBSD/devel/cgit-causal-agency/pkg-plist
new file mode 100644
index 0000000..ad44adb
--- /dev/null
+++ b/FreeBSD/devel/cgit-causal-agency/pkg-plist
@@ -0,0 +1,14 @@
+lib/cgit/filters/about-formatting.sh
+lib/cgit/filters/commit-links.sh
+lib/cgit/filters/email-gravatar.py
+lib/cgit/filters/html-converters/man2html
+lib/cgit/filters/html-converters/md2html
+lib/cgit/filters/html-converters/rst2html
+lib/cgit/filters/html-converters/txt2html
+lib/cgit/filters/syntax-highlighting.py
+lib/cgit/filters/syntax-highlighting.sh
+%%ASCIIDOC%%man/man5/cgitrc.5.gz
+%%WWWDIR%%/cgit.cgi
+%%WWWDIR%%/cgit.css
+%%WWWDIR%%/cgit.png
+%%WWWDIR%%/robots.txt