summary refs log tree commit diff
path: root/FreeBSD/irc/pounce
diff options
context:
space:
mode:
Diffstat (limited to 'FreeBSD/irc/pounce')
-rw-r--r--FreeBSD/irc/pounce/Makefile29
-rw-r--r--FreeBSD/irc/pounce/distinfo3
-rw-r--r--FreeBSD/irc/pounce/pkg-descr5
3 files changed, 37 insertions, 0 deletions
diff --git a/FreeBSD/irc/pounce/Makefile b/FreeBSD/irc/pounce/Makefile
new file mode 100644
index 0000000..92c806a
--- /dev/null
+++ b/FreeBSD/irc/pounce/Makefile
@@ -0,0 +1,29 @@
+PORTNAME=	pounce
+DISTVERSION=	2.5
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/pounce/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Multi-client IRC bouncer
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/calico \
+		bin/pounce \
+		man/man1/calico.1.gz \
+		man/man1/pounce.1.gz
+
+post-install:
+.for b in calico pounce
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${b}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/irc/pounce/distinfo b/FreeBSD/irc/pounce/distinfo
new file mode 100644
index 0000000..0f0a2dc
--- /dev/null
+++ b/FreeBSD/irc/pounce/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1630978050
+SHA256 (pounce-2.5.tar.gz) = c3f88f85ea6b3211d77b8193731704cb01871aee68762d2f6b5e9b102f83d0ad
+SIZE (pounce-2.5.tar.gz) = 52471
diff --git a/FreeBSD/irc/pounce/pkg-descr b/FreeBSD/irc/pounce/pkg-descr
new file mode 100644
index 0000000..68679a2
--- /dev/null
+++ b/FreeBSD/irc/pounce/pkg-descr
@@ -0,0 +1,5 @@
+pounce is a multi-client, TLS-only IRC bouncer. It takes a simple
+approach, using a multiple-consumer ring buffer and the IRCv3.2
+server-time extension to communicate with clients.
+
+WWW: https://git.causal.agency/pounce/