summary refs log tree commit diff
path: root/FreeBSD/irc/scooper/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'FreeBSD/irc/scooper/Makefile')
-rw-r--r--FreeBSD/irc/scooper/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/FreeBSD/irc/scooper/Makefile b/FreeBSD/irc/scooper/Makefile
new file mode 100644
index 0000000..1f9df37
--- /dev/null
+++ b/FreeBSD/irc/scooper/Makefile
@@ -0,0 +1,26 @@
+PORTNAME=	scooper
+DISTVERSION=	1.3
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/scooper/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Web interface for litterbox
+
+LICENSE=	AGPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+BUILD_DEPENDS=	${LOCALBASE}/lib/libkcgi.a:www/kcgi \
+		${LOCALBASE}/lib/libkcgihtml.a:www/kcgi
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/scooper \
+		man/man1/scooper.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/scooper
+
+.include <bsd.port.mk>