summary refs log tree commit diff
path: root/FreeBSD/mail/bubger
diff options
context:
space:
mode:
Diffstat (limited to 'FreeBSD/mail/bubger')
-rw-r--r--FreeBSD/mail/bubger/Makefile27
-rw-r--r--FreeBSD/mail/bubger/distinfo3
-rw-r--r--FreeBSD/mail/bubger/pkg-descr6
3 files changed, 36 insertions, 0 deletions
diff --git a/FreeBSD/mail/bubger/Makefile b/FreeBSD/mail/bubger/Makefile
new file mode 100644
index 0000000..9f6d98f
--- /dev/null
+++ b/FreeBSD/mail/bubger/Makefile
@@ -0,0 +1,27 @@
+PORTNAME=	bubger
+DISTVERSION=	1.1
+CATEGORIES=	mail
+MASTER_SITES=	https://git.causal.agency/bubger/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	IMAP archive generator
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	iconv pkgconfig
+CFLAGS+=	-I${ICONV_PREFIX}/include
+LDFLAGS+=	-L${ICONV_PREFIX}/lib ${ICONV_LIB}
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/bubger \
+		man/man1/bubger.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/bubger
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/mail/bubger/distinfo b/FreeBSD/mail/bubger/distinfo
new file mode 100644
index 0000000..77fb94f
--- /dev/null
+++ b/FreeBSD/mail/bubger/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1623954809
+SHA256 (bubger-1.1.tar.gz) = 867b7c055a2e81384e9bcdcd12ecf38c0e78891e9768b697875547e0ce4d9904
+SIZE (bubger-1.1.tar.gz) = 38573
diff --git a/FreeBSD/mail/bubger/pkg-descr b/FreeBSD/mail/bubger/pkg-descr
new file mode 100644
index 0000000..1532b98
--- /dev/null
+++ b/FreeBSD/mail/bubger/pkg-descr
@@ -0,0 +1,6 @@
+bubger is a mailing list archive generator for mail stored in IMAP.
+It produces static files of HTML, Atom and mboxrd, making its output
+easy to serve from a host without IMAP access. It requires the IMAP
+THREAD extension.
+
+WWW: https://git.causal.agency/bubger/