summary refs log tree commit diff
path: root/FreeBSD/mail
diff options
context:
space:
mode:
Diffstat (limited to 'FreeBSD/mail')
-rw-r--r--FreeBSD/mail/bubger/Makefile27
-rw-r--r--FreeBSD/mail/bubger/distinfo3
-rw-r--r--FreeBSD/mail/bubger/pkg-descr6
-rw-r--r--FreeBSD/mail/imbox/Makefile27
-rw-r--r--FreeBSD/mail/imbox/distinfo3
-rw-r--r--FreeBSD/mail/imbox/pkg-descr5
-rw-r--r--FreeBSD/mail/notemap/Makefile27
-rw-r--r--FreeBSD/mail/notemap/distinfo3
-rw-r--r--FreeBSD/mail/notemap/pkg-descr4
9 files changed, 105 insertions, 0 deletions
diff --git a/FreeBSD/mail/bubger/Makefile b/FreeBSD/mail/bubger/Makefile
new file mode 100644
index 0000000..9f6d98f
--- /dev/null
+++ b/FreeBSD/mail/bubger/Makefile
@@ -0,0 +1,27 @@
+PORTNAME=	bubger
+DISTVERSION=	1.1
+CATEGORIES=	mail
+MASTER_SITES=	https://git.causal.agency/bubger/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	IMAP archive generator
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	iconv pkgconfig
+CFLAGS+=	-I${ICONV_PREFIX}/include
+LDFLAGS+=	-L${ICONV_PREFIX}/lib ${ICONV_LIB}
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/bubger \
+		man/man1/bubger.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/bubger
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/mail/bubger/distinfo b/FreeBSD/mail/bubger/distinfo
new file mode 100644
index 0000000..77fb94f
--- /dev/null
+++ b/FreeBSD/mail/bubger/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1623954809
+SHA256 (bubger-1.1.tar.gz) = 867b7c055a2e81384e9bcdcd12ecf38c0e78891e9768b697875547e0ce4d9904
+SIZE (bubger-1.1.tar.gz) = 38573
diff --git a/FreeBSD/mail/bubger/pkg-descr b/FreeBSD/mail/bubger/pkg-descr
new file mode 100644
index 0000000..1532b98
--- /dev/null
+++ b/FreeBSD/mail/bubger/pkg-descr
@@ -0,0 +1,6 @@
+bubger is a mailing list archive generator for mail stored in IMAP.
+It produces static files of HTML, Atom and mboxrd, making its output
+easy to serve from a host without IMAP access. It requires the IMAP
+THREAD extension.
+
+WWW: https://git.causal.agency/bubger/
diff --git a/FreeBSD/mail/imbox/Makefile b/FreeBSD/mail/imbox/Makefile
new file mode 100644
index 0000000..5f83e69
--- /dev/null
+++ b/FreeBSD/mail/imbox/Makefile
@@ -0,0 +1,27 @@
+PORTNAME=	imbox
+DISTVERSION=	1.4
+CATEGORIES=	mail
+MASTER_SITES=	https://git.causal.agency/imbox/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	IMAP to mbox
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/git-fetch-email \
+		bin/imbox \
+		man/man1/git-fetch-email.1.gz \
+		man/man1/imbox.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/imbox
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/mail/imbox/distinfo b/FreeBSD/mail/imbox/distinfo
new file mode 100644
index 0000000..e7afbd3
--- /dev/null
+++ b/FreeBSD/mail/imbox/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1615244342
+SHA256 (imbox-1.4.tar.gz) = 0a264f58f7306d8481a559220cc20a0673a425581d4805b3f7a02dcb61fc9b3a
+SIZE (imbox-1.4.tar.gz) = 23083
diff --git a/FreeBSD/mail/imbox/pkg-descr b/FreeBSD/mail/imbox/pkg-descr
new file mode 100644
index 0000000..76aa3e6
--- /dev/null
+++ b/FreeBSD/mail/imbox/pkg-descr
@@ -0,0 +1,5 @@
+imbox is a small TLS-only IMAP client intended for applying git patches
+without need of any other mail client. It includes git-fetch-email, a
+wrapper modeled after git-send-email.
+
+WWW: https://git.causal.agency/imbox/
diff --git a/FreeBSD/mail/notemap/Makefile b/FreeBSD/mail/notemap/Makefile
new file mode 100644
index 0000000..d5220b3
--- /dev/null
+++ b/FreeBSD/mail/notemap/Makefile
@@ -0,0 +1,27 @@
+PORTNAME=	notemap
+DISTVERSION=	1.3
+CATEGORIES=	mail
+MASTER_SITES=	https://git.causal.agency/notemap/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	mirror notes to IMAP
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libretls
+
+USES=	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/git-notemap \
+		bin/notemap \
+		man/man1/git-notemap.1.gz \
+		man/man1/notemap.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/notemap
+
+.include <bsd.port.mk>
diff --git a/FreeBSD/mail/notemap/distinfo b/FreeBSD/mail/notemap/distinfo
new file mode 100644
index 0000000..135e1c3
--- /dev/null
+++ b/FreeBSD/mail/notemap/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1608333183
+SHA256 (notemap-1.3.tar.gz) = 76f9f44963546d443420f03159d6bebfd4d661a67dd8e4e59ccde5d23f51c68d
+SIZE (notemap-1.3.tar.gz) = 22773
diff --git a/FreeBSD/mail/notemap/pkg-descr b/FreeBSD/mail/notemap/pkg-descr
new file mode 100644
index 0000000..67622a8
--- /dev/null
+++ b/FreeBSD/mail/notemap/pkg-descr
@@ -0,0 +1,4 @@
+notemap mirrors text files to an IMAP mailbox in a format compatible
+with the iOS Notes app.
+
+WWW: https://git.causal.agency/notemap/