summary refs log tree commit diff
path: root/FreeBSD/sysutils/catsit/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'FreeBSD/sysutils/catsit/Makefile')
-rw-r--r--FreeBSD/sysutils/catsit/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/FreeBSD/sysutils/catsit/Makefile b/FreeBSD/sysutils/catsit/Makefile
new file mode 100644
index 0000000..c65563f
--- /dev/null
+++ b/FreeBSD/sysutils/catsit/Makefile
@@ -0,0 +1,28 @@
+PORTNAME=	catsit
+DISTVERSION=	1.4
+CATEGORIES=	sysutils
+MASTER_SITES=	https://git.causal.agency/catsit/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Process supervisor
+
+LICENSE=	AGPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+PLIST_FILES=	bin/catsit-timer \
+		bin/catsit-watch \
+		etc/rc.d/catsitd \
+		man/man1/catsit-timer.1.gz \
+		man/man1/catsit-watch.1.gz \
+		man/man5/catsit.conf.5.gz \
+		man/man8/catsit.8.gz \
+		man/man8/catsitd.8.gz \
+		sbin/catsit \
+		sbin/catsitd
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/catsit-timer
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/catsit-watch
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/catsitd
+
+.include <bsd.port.mk>
gml.c?id=a34bb3c52fb4ee039b05434189f58367aece20c7&follow=1'>Prevent matching the same tag twiceJune McEnroe 2021-01-12Process htagml file line by lineJune McEnroe This simplifies some things, adds support for line number tag definitions, and should enable combining htagml with other preprocessors in the future. 2021-01-12Split fields by tab onlyJune McEnroe Also don't fail hard on non-forward-search definitions. 2021-01-12List both Makefile and html.sh under README.7June McEnroe 2021-01-12Add htagml exampleJune McEnroe 2021-01-12Use mandoc and htagml for bin htmlJune McEnroe 2021-01-12Add htagmlJune McEnroe 2021-01-12Replace causal.agency with a simple mdoc pageJune McEnroe 2021-01-11Publish "Using vi"June McEnroe 2021-01-11Enable diff.colorMovedJune McEnroe 2021-01-10Set less search case-insensitiveJune McEnroe 2021-01-10Set EXINITJune McEnroe neovim is laggy as hell in my OpenBSD VM, so I switched to vi so I could type without getting frustrated. 2021-01-09Add c -t flag to print expression typeJune McEnroe Also add missing float case. 2021-01-05Update taglineJune McEnroe