summary refs log tree commit diff
path: root/OpenBSD/www/cgit-causal-agency/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'OpenBSD/www/cgit-causal-agency/Makefile')
-rw-r--r--OpenBSD/www/cgit-causal-agency/Makefile42
1 files changed, 0 insertions, 42 deletions
diff --git a/OpenBSD/www/cgit-causal-agency/Makefile b/OpenBSD/www/cgit-causal-agency/Makefile
deleted file mode 100644
index f7f03a8..0000000
--- a/OpenBSD/www/cgit-causal-agency/Makefile
+++ /dev/null
@@ -1,42 +0,0 @@
-# $OpenBSD: Makefile,v 1.27 2020/04/04 19:28:31 kn Exp $
-
-COMMENT =	web frontend for git repositories
-
-PKGNAME =	cgit-causal-agency-20210930
-DISTNAME =	src-db96234ccb8c33dfdf127eb7e254a84481f98aa1
-CATEGORIES =	www devel
-REVISION =	2
-
-DISTFILES =	${DISTNAME}.tar.gz:0 \
-		git-2.32.0.tar.gz:1
-
-WRKDIST =	${WRKDIR}/${DISTNAME}/www/git.causal.agency/cgit
-
-MASTER_SITES0 =		https://git.causal.agency/src/snapshot/
-MASTER_SITES1 =		https://www.kernel.org/pub/software/scm/git/
-HOMEPAGE =		https://git.causal.agency/src/log/www/git.causal.agency/cgit
-
-# GPLv2
-PERMIT_PACKAGE =	Yes
-
-USE_GMAKE =	yes
-
-BUILD_DEPENDS =	textproc/asciidoc
-LIB_DEPENDS =	converters/libiconv
-
-PREFIX =	${VARBASE}/www
-MAKE_FLAGS +=	V=1 NO_GETTEXT=1 EXTRA_GIT_TARGETS='git git-http-backend' LDFLAGS+='${STATIC} -L${LOCALBASE}/lib'
-
-ALL_TARGET =	all doc-man
-
-post-extract:
-	mv ${WRKDIR}/git-* ${WRKSRC}/git
-
-post-install:
-	mv ${PREFIX}/htdocs ${PREFIX}/cgit
-	${INSTALL_MAN} ${WRKBUILD}/cgitrc.5 ${WRKINST}${LOCALBASE}/man/man5
-	${INSTALL_PROGRAM_DIR} ${PREFIX}/bin
-	${INSTALL_PROGRAM} ${WRKBUILD}/git/git ${PREFIX}/bin
-	${INSTALL_PROGRAM} ${WRKBUILD}/git/git-http-backend ${PREFIX}/cgi-bin
-
-.include <bsd.port.mk>