summary refs log tree commit diff
path: root/OpenBSD/www/cgit-causal-agency/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'OpenBSD/www/cgit-causal-agency/Makefile')
-rw-r--r--OpenBSD/www/cgit-causal-agency/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/OpenBSD/www/cgit-causal-agency/Makefile b/OpenBSD/www/cgit-causal-agency/Makefile
new file mode 100644
index 0000000..87241a0
--- /dev/null
+++ b/OpenBSD/www/cgit-causal-agency/Makefile
@@ -0,0 +1,38 @@
+# $OpenBSD: Makefile,v 1.27 2020/04/04 19:28:31 kn Exp $
+
+COMMENT =	web frontend for git repositories
+
+PKGNAME =	cgit-causal-agency-20210922
+DISTNAME =	src-5a8f6f3698fbd69b97483c7b84bf661f4761124f
+CATEGORIES =	www devel
+
+DISTFILES =	${DISTNAME}.tar.gz:0 \
+		git-2.32.0.tar.gz:1
+
+WRKDIST =	${WRKDIR}/${DISTNAME}/www/git.causal.agency/cgit
+
+MASTER_SITES0 =		https://git.causal.agency/src/snapshot/
+MASTER_SITES1 =		https://www.kernel.org/pub/software/scm/git/
+HOMEPAGE =		https://git.causal.agency/src/log/www/git.causal.agency/cgit
+
+# GPLv2
+PERMIT_PACKAGE =	Yes
+
+USE_GMAKE =	yes
+
+BUILD_DEPENDS =	textproc/asciidoc
+LIB_DEPENDS =	converters/libiconv
+
+PREFIX =	${VARBASE}/www
+MAKE_FLAGS +=	V=1 NO_GETTEXT=1 LDFLAGS+='${STATIC} -L${LOCALBASE}/lib'
+
+ALL_TARGET =	all doc-man
+
+post-extract:
+	mv ${WRKDIR}/git-* ${WRKSRC}/git
+
+post-install:
+	mv ${PREFIX}/htdocs ${PREFIX}/cgit
+	${INSTALL_MAN} ${WRKBUILD}/cgitrc.5 ${WRKINST}${LOCALBASE}/man/man5
+
+.include <bsd.port.mk>