summary refs log tree commit diff
path: root/OpenBSD/www/cgit-causal-agency/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'OpenBSD/www/cgit-causal-agency/Makefile')
-rw-r--r--OpenBSD/www/cgit-causal-agency/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/OpenBSD/www/cgit-causal-agency/Makefile b/OpenBSD/www/cgit-causal-agency/Makefile
index ee4850c..f7f03a8 100644
--- a/OpenBSD/www/cgit-causal-agency/Makefile
+++ b/OpenBSD/www/cgit-causal-agency/Makefile
@@ -5,6 +5,7 @@ COMMENT =	web frontend for git repositories
 PKGNAME =	cgit-causal-agency-20210930
 DISTNAME =	src-db96234ccb8c33dfdf127eb7e254a84481f98aa1
 CATEGORIES =	www devel
+REVISION =	2
 
 DISTFILES =	${DISTNAME}.tar.gz:0 \
 		git-2.32.0.tar.gz:1
@@ -24,7 +25,7 @@ BUILD_DEPENDS =	textproc/asciidoc
 LIB_DEPENDS =	converters/libiconv
 
 PREFIX =	${VARBASE}/www
-MAKE_FLAGS +=	V=1 NO_GETTEXT=1 LDFLAGS+='${STATIC} -L${LOCALBASE}/lib'
+MAKE_FLAGS +=	V=1 NO_GETTEXT=1 EXTRA_GIT_TARGETS='git git-http-backend' LDFLAGS+='${STATIC} -L${LOCALBASE}/lib'
 
 ALL_TARGET =	all doc-man
 
@@ -34,5 +35,8 @@ post-extract:
 post-install:
 	mv ${PREFIX}/htdocs ${PREFIX}/cgit
 	${INSTALL_MAN} ${WRKBUILD}/cgitrc.5 ${WRKINST}${LOCALBASE}/man/man5
+	${INSTALL_PROGRAM_DIR} ${PREFIX}/bin
+	${INSTALL_PROGRAM} ${WRKBUILD}/git/git ${PREFIX}/bin
+	${INSTALL_PROGRAM} ${WRKBUILD}/git/git-http-backend ${PREFIX}/cgi-bin
 
 .include <bsd.port.mk>