summary refs log tree commit diff
path: root/OpenBSD/www/cgit-pink/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'OpenBSD/www/cgit-pink/Makefile')
-rw-r--r--OpenBSD/www/cgit-pink/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/OpenBSD/www/cgit-pink/Makefile b/OpenBSD/www/cgit-pink/Makefile
new file mode 100644
index 0000000..845c0f9
--- /dev/null
+++ b/OpenBSD/www/cgit-pink/Makefile
@@ -0,0 +1,39 @@
+# $OpenBSD: Makefile,v 1.27 2020/04/04 19:28:31 kn Exp $
+
+COMMENT =	web frontend for git repositories
+
+DISTNAME =	cgit-pink-1.3.0
+CATEGORIES =	www devel
+
+DISTFILES =	${DISTNAME}.tar.gz:0 \
+		git-2.35.1.tar.gz:1
+
+MASTER_SITES0 =		https://git.causal.agency/cgit-pink/snapshot/
+MASTER_SITES1 =		https://www.kernel.org/pub/software/scm/git/
+HOMEPAGE =		https://git.causal.agency/cgit-pink/about/
+
+# GPLv2
+PERMIT_PACKAGE =	Yes
+
+USE_GMAKE =	yes
+
+BUILD_DEPENDS =	textproc/asciidoc
+LIB_DEPENDS =	converters/libiconv
+
+PREFIX =	${VARBASE}/www
+MAKE_FLAGS +=	V=1 NO_GETTEXT=1 EXTRA_GIT_TARGETS='git git-http-backend' LDFLAGS+='${STATIC} -L${LOCALBASE}/lib'
+
+ALL_TARGET =	all doc-man
+
+post-extract:
+	rmdir ${WRKSRC}/git
+	mv ${WRKDIR}/git-* ${WRKSRC}/git
+
+post-install:
+	mv ${PREFIX}/htdocs ${PREFIX}/cgit
+	${INSTALL_MAN} ${WRKBUILD}/cgitrc.5 ${WRKINST}${LOCALBASE}/man/man5
+	${INSTALL_PROGRAM_DIR} ${PREFIX}/bin
+	${INSTALL_PROGRAM} ${WRKBUILD}/git/git ${PREFIX}/bin
+	${INSTALL_PROGRAM} ${WRKBUILD}/git/git-http-backend ${PREFIX}/cgi-bin
+
+.include <bsd.port.mk>