summary refs log tree commit diff
path: root/devel/cgit-causal-agency/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cgit-causal-agency/Makefile')
-rw-r--r--devel/cgit-causal-agency/Makefile73
1 files changed, 0 insertions, 73 deletions
diff --git a/devel/cgit-causal-agency/Makefile b/devel/cgit-causal-agency/Makefile
deleted file mode 100644
index 6ffd004..0000000
--- a/devel/cgit-causal-agency/Makefile
+++ /dev/null
@@ -1,73 +0,0 @@
-# $FreeBSD: head/devel/cgit/Makefile 523699 2020-01-21 01:37:59Z meta $
-
-PORTNAME=	cgit-causal-agency
-PORTVERSION=	1.2.3
-CONFLICTS_INSTALL=	cgit
-CATEGORIES=	devel www
-MASTER_SITES=	https://git.causal.agency/src/snapshot/:src \
-		KERNEL_ORG/software/scm/git:git
-DISTFILES=	src-${SRC_VERSION}${EXTRACT_SUFX}:src \
-		git-${GIT_VERSION}${EXTRACT_SUFX}:git
-DISTNAME=	src-${SRC_VERSION}
-
-MAINTAINER=	june@causal.agency
-COMMENT=	Fast, lightweight web frontend for Git repositories
-
-LICENSE=	GPLv2
-LICENSE_FILE=	${WRKSRC}/COPYING
-
-TEST_DEPENDS=	msgfmt:devel/gettext-tools
-
-SRC_VERSION=	8e4c63c857f9320d2eaae1ce5bdbced4ec92dbff
-GIT_VERSION=	2.25.1
-WRKSRC_SUBDIR=	www/git.causal.agency/cgit
-
-USES=		cpe gmake iconv perl5 python:3.2+,env shebangfix ssl
-CPE_VENDOR=	lars_hjemli
-USE_PERL5=	test
-SHEBANG_FILES=	filters/email-gravatar.py \
-		filters/html-converters/md2html \
-		filters/html-converters/rst2html \
-		filters/syntax-highlighting.py
-WWWDIR=	${PREFIX}/www/cgit
-
-CFLAGS+=	-I${LOCALBASE}/include
-LDFLAGS+=	-L${LOCALBASE}/lib ${ICONV_LIB}
-MAKE_ARGS+=	CGIT_SCRIPT_PATH=${WWWDIR} CGIT_CONFIG=${PREFIX}/etc/cgitrc \
-		prefix=${PREFIX} NO_GETTEXT=1 NO_R_TO_GCC_LINKER=1 V=1
-
-SUB_FILES=	pkg-message
-
-PORTDOCS=	cgitrc.5.txt
-
-OPTIONS_DEFINE=	DOCS ASCIIDOC
-OPTIONS_DEFAULT=	ASCIIDOC
-OPTIONS_SUB=	yes
-
-ASCIIDOC_DESC=	Use asciidoc to preprocess man page
-ASCIIDOC_BUILD_DEPENDS=	a2x:textproc/asciidoc
-
-post-extract:
-	@${MV} ${WRKDIR}/git-${GIT_VERSION} ${WRKSRC}/git
-
-post-patch:
-	@${REINPLACE_CMD} -e 's/^\(GIT_VER =\).*$$/\1 ${GIT_VERSION}/' \
-		${WRKSRC}/Makefile
-
-	@${REINPLACE_CMD} -e 's/-liconv/${ICONV_LIB}/' \
-		-e "s|\(ALL_CFLAGS =\)|\1 -I${OPENSSLINC}|g" \
-		-e "s|\(ALL_LDFLAGS =\)|\1 -L${OPENSSLLIB}|g" \
-		${WRKSRC}/git/Makefile
-
-post-install:
-	${STRIP_CMD} ${STAGEDIR}${WWWDIR}/cgit.cgi
-
-post-install-DOCS-on:
-	@${MKDIR} ${STAGEDIR}${DOCSDIR}
-	${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-
-post-install-ASCIIDOC-on:
-	a2x --doctype manpage --format manpage ${WRKSRC}/cgitrc.5.txt
-	${INSTALL_MAN} ${WRKSRC}/cgitrc.5 ${STAGEDIR}${PREFIX}/man/man5
-
-.include <bsd.port.mk>