summary refs log tree commit diff
path: root/devel/cgit-patched/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/cgit-patched/Makefile')
-rw-r--r--devel/cgit-patched/Makefile71
1 files changed, 71 insertions, 0 deletions
diff --git a/devel/cgit-patched/Makefile b/devel/cgit-patched/Makefile
new file mode 100644
index 0000000..670897e
--- /dev/null
+++ b/devel/cgit-patched/Makefile
@@ -0,0 +1,71 @@
+# $FreeBSD: head/devel/cgit/Makefile 523699 2020-01-21 01:37:59Z meta $
+
+PORTNAME=	cgit-patched
+PORTVERSION=	1.2.3p3
+CONFLICTS_INSTALL=	cgit
+CATEGORIES=	devel www
+MASTER_SITES=	https://git.causal.agency/cgit/snapshot/:cgit \
+		KERNEL_ORG/software/scm/git:git
+DISTFILES=	cgit-${PORTVERSION}${EXTRACT_SUFX}:cgit \
+		git-${GIT_VERSION}${EXTRACT_SUFX}:git
+DISTNAME=	cgit-${DISTVERSION}
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Fast, lightweight web frontend for Git repositories
+
+LICENSE=	GPLv2
+LICENSE_FILE=	${WRKSRC}/COPYING
+
+TEST_DEPENDS=	msgfmt:devel/gettext-tools
+
+GIT_VERSION=	2.25.0
+USES=		cpe gmake iconv perl5 python:3.2+,env shebangfix ssl
+CPE_VENDOR=	lars_hjemli
+USE_PERL5=	test
+SHEBANG_FILES=	filters/email-gravatar.py \
+		filters/html-converters/md2html \
+		filters/html-converters/rst2html \
+		filters/syntax-highlighting.py
+WWWDIR=	${PREFIX}/www/cgit
+
+CFLAGS+=	-I${LOCALBASE}/include
+LDFLAGS+=	-L${LOCALBASE}/lib ${ICONV_LIB}
+MAKE_ARGS+=	CGIT_SCRIPT_PATH=${WWWDIR} CGIT_CONFIG=${PREFIX}/etc/cgitrc \
+		prefix=${PREFIX} NO_GETTEXT=1 NO_LUA=1 NO_R_TO_GCC_LINKER=1 V=1
+
+SUB_FILES=	pkg-message
+
+PORTDOCS=	cgitrc.5.txt
+
+OPTIONS_DEFINE=	DOCS ASCIIDOC
+OPTIONS_DEFAULT=	ASCIIDOC
+OPTIONS_SUB=	yes
+
+ASCIIDOC_DESC=	Use asciidoc to preprocess man page
+ASCIIDOC_BUILD_DEPENDS=	a2x:textproc/asciidoc
+
+post-extract:
+	@${RMDIR} ${WRKSRC}/git
+	@${MV} ${WRKDIR}/git-${GIT_VERSION} ${WRKSRC}/git
+
+post-patch:
+	@${REINPLACE_CMD} -e 's/^\(GIT_VER =\).*$$/\1 ${GIT_VERSION}/' \
+		${WRKSRC}/Makefile
+
+	@${REINPLACE_CMD} -e 's/-liconv/${ICONV_LIB}/' \
+		-e "s|\(ALL_CFLAGS =\)|\1 -I${OPENSSLINC}|g" \
+		-e "s|\(ALL_LDFLAGS =\)|\1 -L${OPENSSLLIB}|g" \
+		${WRKSRC}/git/Makefile
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${WWWDIR}/cgit.cgi
+
+post-install-DOCS-on:
+	@${MKDIR} ${STAGEDIR}${DOCSDIR}
+	${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+post-install-ASCIIDOC-on:
+	a2x --doctype manpage --format manpage ${WRKSRC}/cgitrc.5.txt
+	${INSTALL_MAN} ${WRKSRC}/cgitrc.5 ${STAGEDIR}${PREFIX}/man/man5
+
+.include <bsd.port.mk>