summary refs log tree commit diff
path: root/irc/catgirl
diff options
context:
space:
mode:
Diffstat (limited to 'irc/catgirl')
-rw-r--r--irc/catgirl/Makefile29
-rw-r--r--irc/catgirl/distinfo3
-rw-r--r--irc/catgirl/pkg-descr4
3 files changed, 36 insertions, 0 deletions
diff --git a/irc/catgirl/Makefile b/irc/catgirl/Makefile
new file mode 100644
index 0000000..cf5d9f9
--- /dev/null
+++ b/irc/catgirl/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME=	catgirl
+DISTVERSION=	1.1
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/catgirl/snapshot/
+
+MAINTAINER=	june@causal.agency
+COMMENT=	TLS-only terminal IRC client
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKSRC}/LICENSE
+
+LIB_DEPENDS=	libtls.so:security/libressl
+RUN_DEPENDS=	${LOCALBASE}/bin/openssl:security/libressl
+
+USES=	ncurses \
+	pkgconfig
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/catgirl \
+		man/man1/catgirl.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/catgirl
+
+.include <bsd.port.mk>
diff --git a/irc/catgirl/distinfo b/irc/catgirl/distinfo
new file mode 100644
index 0000000..8ed0341
--- /dev/null
+++ b/irc/catgirl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1595877167
+SHA256 (catgirl-1.1.tar.gz) = f6dad1403485984f903630e63a4fedcf8ab08de837453b27df256eb1afe8c1a9
+SIZE (catgirl-1.1.tar.gz) = 52169
diff --git a/irc/catgirl/pkg-descr b/irc/catgirl/pkg-descr
new file mode 100644
index 0000000..8cae8df
--- /dev/null
+++ b/irc/catgirl/pkg-descr
@@ -0,0 +1,4 @@
+catgirl is a TLS-only terminal IRC client with tab-complete, nick
+coloring, URL detection, message filtering and split scrolling.
+
+WWW: https://git.causal.agency/catgirl/
td/> 2021-02-07Fix cwm window cycling, move big by defaultJune McEnroe 2021-02-07Use class names for Foreground, Background, BorderColorJune McEnroe I'm not really sure what difference this makes, but it seems like the right thing to do to be generic? 2021-02-07Add simple battery status and clock to xsessionJune McEnroe I love how simple this is. 2021-02-07Set cursor theme and sizeJune McEnroe 2021-02-07Use scrot for up -s if no screencaptureJune McEnroe Still missing putting the URL in an X selection. 2021-02-07Enable mouse acceleration in XJune McEnroe 2021-02-07Set colours for Xt and cwmJune McEnroe And increase XTerm internalBorder. 2021-02-07Set urgency on bell in xtermJune McEnroe 2021-02-07Add bindings for brightness controlJune McEnroe Weirdly the Fn key doesn't change how the F row registers... I wonder if I can do something about that. 2021-02-07Set X key repeat rateJune McEnroe 2021-02-07Bump font size to 12June McEnroe 11 is what I use on macOS, but I feel like my eyes are working harder here. 2021-02-07Fully configure and rebind cwmJune McEnroe This is sort of a mix of trying to emulate macOS somewhat for my muscle memory and just rebinding some of the cwm defaults to use 4- rather than M-. 2021-02-07Add BintiJune McEnroe 2021-02-07Finish configuring xtermJune McEnroe 2021-02-06Enable tapping, reverse scroll, set scaling in wsconsctlJune McEnroe 2021-02-06Set root window to black on purple snowJune McEnroe 2021-02-06Add xmodmap configurationJune McEnroe 2021-02-06Add initial OpenBSD X configurationJune McEnroe cwm still needs a lot more rebinding, and I need to actually look at its other options. xterm definitely still needs some configuration, but I at least managed to get it to use a decent looking font. Very happy that OpenBSD includes Luxi Mono, which is what my usual font, Go Mono, is based on anyway. Still missing is xmodmap and such. 2021-02-06Add xterm output to schemeJune McEnroe