summary refs log tree commit diff
path: root/irc/pounce-palaver/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/pounce-palaver/Makefile')
-rw-r--r--irc/pounce-palaver/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/irc/pounce-palaver/Makefile b/irc/pounce-palaver/Makefile
new file mode 100644
index 0000000..67bb470
--- /dev/null
+++ b/irc/pounce-palaver/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME=	pounce-palaver
+DISTVERSION=	2.0
+CATEGORIES=	irc
+MASTER_SITES=	https://git.causal.agency/pounce/snapshot/
+DISTNAME=	pounce-${DISTVERSION}
+
+MAINTAINER=	june@causal.agency
+COMMENT=	Palaver push notifications for pounce
+
+LICENSE=	GPLv3+
+LICENSE_FILE=	${WRKDIR}/${DISTNAME}/LICENSE
+
+LIB_DEPENDS=	libcurl.so:ftp/curl \
+		libsqlite3.so:databases/sqlite3 \
+		libtls.so:security/libretls
+
+USES=	pkgconfig
+
+WRKSRC_SUBDIR=	contrib/palaver
+
+HAS_CONFIGURE=	yes
+CONFIGURE_ARGS=	--prefix=${PREFIX} --mandir=${MANPREFIX}/man
+
+PLIST_FILES=	bin/pounce-palaver \
+		man/man1/pounce-palaver.1.gz
+
+post-install:
+	${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/pounce-palaver
+
+.include <bsd.port.mk>