summary refs log tree commit diff
path: root/security/libretls/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/libretls/Makefile')
-rw-r--r--security/libretls/Makefile21
1 files changed, 6 insertions, 15 deletions
diff --git a/security/libretls/Makefile b/security/libretls/Makefile
index ca29014..5fca48e 100644
--- a/security/libretls/Makefile
+++ b/security/libretls/Makefile
@@ -1,28 +1,19 @@
-# $FreeBSD$
+# $FreeBSD: head/security/libretls/Makefile 561899 2021-01-18 07:55:49Z bapt $
 
 PORTNAME=	libretls
 PORTVERSION=	3.3.1
 CATEGORIES=	security devel
 MASTER_SITES=	https://causal.agency/libretls/
 
-MAINTAINER=	june@causal.agency
-COMMENT=	Port of libtls for OpenSSL
+MAINTAINER=	bapt@FreeBSD.org
+COMMENT=	TLS library designed to ease writing foolproof applications
 
 LICENSE=	ISCL
 
-BROKEN_SSL=			libressl
-BROKEN_SSL_REASON_libressl=	libtls is provided by LibreSSL
-
-USES=		libtool pathfix pkgconfig ssl
-USE_LDCONFIG=	yes
+USES=	libtool ssl pkgconfig
+INSTALL_TARGET=	install-strip
 GNU_CONFIGURE=	yes
-CONFIGURE_ARGS+=	--with-openssl=${OPENSSLBASE}
-CFLAGS+=	-fpic -DPIC -Wl,-rpath,${PREFIX}/lib -Wl,--as-needed
-LDFLAGS+=	-pthread
 
-CONFLICTS_INSTALL=	libressl-[0-9]* \
-			libressl-devel-[0-9]*
-
-INSTALL_TARGET=		install-strip
+USE_LDCONFIG=	yes
 
 .include <bsd.port.mk>